Mailinglist Archive: opensuse-updates (200 mails)

< Previous Next >
openSUSE-SU-2013:1016-1: moderate: update for nfs-utils
openSUSE Security Update: update for nfs-utils

Announcement ID: openSUSE-SU-2013:1016-1
Rating: moderate
References: #809226 #813464 #817651
Cross-References: CVE-2013-1923
Affected Products:
openSUSE 12.3

An update that solves one vulnerability and has two fixes
is now available.


This update of nfs-utils includes several bug and security
- gssd-reverse-dns-fix: Allow DNS lookups to be avoided
when determining kerberos identity of server. The
GSSD_OPTIONS sysconfig variable is added so that use of
DNS can be enforced for sites that need it. (bnc#813464
- gssd-n.fix: linux-3.7 changed behaviour of gssd lookups
so that "gssd -n" isn't sufficient to stop the use of
"machine credentials". This patch add "-N" which stops
the new use as well. Also add GSSD_OPTIONS to sysconfig
so these flags can be set more easily. (bnc#817651)
- mountd-fix-exporting-of-with-sec-setting.patch Fix bug
when exporting root filesystem with gss security.

- mountd-fix-error-check.patch: check for errors with
exporting filesystems correctly (bnc#809226)

- nfsserver.init: make sure warning about bind= being
deprecated goes to terminal and not into
/run/nfs/bind.mounts (bnc#809226)

Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.3:

zypper in -t patch openSUSE-2013-493

To bring your system up-to-date, use "zypper patch".

Package List:

- openSUSE 12.3 (i586 x86_64):



< Previous Next >
This Thread
  • No further messages