Mailinglist Archive: opensuse-updates (111 mails)

< Previous Next >
openSUSE-SU-2013:0662-1: moderate: update for rubygem-actionpack-2_3
openSUSE Security Update: update for rubygem-actionpack-2_3
______________________________________________________________________________

Announcement ID: openSUSE-SU-2013:0662-1
Rating: moderate
References: #809935 #809940
Cross-References: CVE-2013-1855 CVE-2013-1857
Affected Products:
openSUSE 12.2
openSUSE 12.1
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:


Changes in rubygem-actionpack-2_3:
- add 2 patches to fix security issues:
- bug-809935_2-3-css_sanitize.patch: CVE-2013-1855:
rubygem-actionpack*: XSS vulnerability in sanitize_css
in Action Pack (bnc#809935)
- bug-809940_2-3-sanitize_protocol.patch: CVE-2013-1857:
rubygem-actionpack*: XSS Vulnerability in the
`sanitize` helper of Ruby on Rails (bnc#809940)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.2:

zypper in -t patch openSUSE-2013-324

- openSUSE 12.1:

zypper in -t patch openSUSE-2013-324

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.2 (i586 x86_64):

rubygem-actionpack-2_3-2.3.17-2.21.1
rubygem-actionpack-2_3-doc-2.3.17-2.21.1
rubygem-actionpack-2_3-testsuite-2.3.17-2.21.1

- openSUSE 12.1 (i586 x86_64):

rubygem-actionpack-2_3-2.3.17-3.24.1
rubygem-actionpack-2_3-doc-2.3.17-3.24.1
rubygem-actionpack-2_3-testsuite-2.3.17-3.24.1


References:

http://support.novell.com/security/cve/CVE-2013-1855.html
http://support.novell.com/security/cve/CVE-2013-1857.html
https://bugzilla.novell.com/809935
https://bugzilla.novell.com/809940


< Previous Next >
This Thread
  • No further messages