Mailinglist Archive: opensuse-updates (94 mails)

< Previous Next >
openSUSE-SU-2013:0192-1: moderate: libtcnative-1-0 and tomcat6
openSUSE Security Update: libtcnative-1-0 and tomcat6
______________________________________________________________________________

Announcement ID: openSUSE-SU-2013:0192-1
Rating: moderate
References: #794548
Cross-References: CVE-2012-4431 CVE-2012-4534
Affected Products:
openSUSE 11.4
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

- fix bnc#794548 - denial of service (CVE-2012-4534)
* apache-tomcat-CVE-2012-4534.patch fixes apache#53138,
apache#52858
http://svn.apache.org/viewvc?view=rev&rev=1372035
- fix a minor issue in apache-tomcat-CVE-2012-4431.patch
use the already initialized session variable instead of
an another call req.getSesssion()


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch 2013-11

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (noarch):

tomcat6-6.0.32-38.1
tomcat6-admin-webapps-6.0.32-38.1
tomcat6-docs-webapp-6.0.32-38.1
tomcat6-el-1_0-api-6.0.32-38.1
tomcat6-javadoc-6.0.32-38.1
tomcat6-jsp-2_1-api-6.0.32-38.1
tomcat6-lib-6.0.32-38.1
tomcat6-servlet-2_5-api-6.0.32-38.1
tomcat6-webapps-6.0.32-38.1


References:

http://support.novell.com/security/cve/CVE-2012-4431.html
http://support.novell.com/security/cve/CVE-2012-4534.html
https://bugzilla.novell.com/794548


< Previous Next >
This Thread
  • No further messages