Mailinglist Archive: opensuse-updates (94 mails)

< Previous Next >
openSUSE-SU-2013:0189-1: moderate: update for freetype2
openSUSE Security Update: update for freetype2
______________________________________________________________________________

Announcement ID: openSUSE-SU-2013:0189-1
Rating: moderate
References:
Cross-References: CVE-2012-5668 CVE-2012-5669
Affected Products:
openSUSE 11.4
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:


- new license string.
- BNC#795826, CVE-2012-5668.patch
- BNC#795826, CVE-2012-5669.patch [bdf] Fix Savannah bug
#37906.
* src/bdf/bdflib.c (_bdf_parse_glyphs): Use correct
array size for checking `glyph_enc'.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch 2013-12

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64):

freetype2-debugsource-2.4.4-7.27.1
freetype2-devel-2.4.4-7.27.1
libfreetype6-2.4.4-7.27.1
libfreetype6-debuginfo-2.4.4-7.27.1

- openSUSE 11.4 (x86_64):

freetype2-devel-32bit-2.4.4-7.27.1
libfreetype6-32bit-2.4.4-7.27.1
libfreetype6-debuginfo-32bit-2.4.4-7.27.1

- openSUSE 11.4 (ia64):

libfreetype6-debuginfo-x86-2.4.4-7.27.1
libfreetype6-x86-2.4.4-7.27.1


References:

http://support.novell.com/security/cve/CVE-2012-5668.html
http://support.novell.com/security/cve/CVE-2012-5669.html


< Previous Next >
This Thread
  • No further messages