Mailinglist Archive: opensuse-updates (94 mails)

< Previous Next >
openSUSE-SU-2013:0161-1: moderate: update for tomcat6
openSUSE Security Update: update for tomcat6
______________________________________________________________________________

Announcement ID: openSUSE-SU-2013:0161-1
Rating: moderate
References: #794548
Cross-References: CVE-2012-4431 CVE-2012-4534
Affected Products:
openSUSE 12.1
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:


- fix bnc#794548 - denial of service (CVE-2012-4534)
* apache-tomcat-CVE-2012-4534.patch fixes apache#53138,
apache#52858
http://svn.apache.org/viewvc?view=rev&rev=1372035
- fix a minor issue in apache-tomcat-CVE-2012-4431.patch
use the already initialized session variable instead of
an another call req.getSesssion()


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.1:

zypper in -t patch openSUSE-2013-23

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.1 (i586 x86_64):

libtcnative-1-0-1.3.3-3.11.1
libtcnative-1-0-debuginfo-1.3.3-3.11.1
libtcnative-1-0-debugsource-1.3.3-3.11.1
libtcnative-1-0-devel-1.3.3-3.11.1

- openSUSE 12.1 (noarch):

tomcat6-6.0.33-3.11.1
tomcat6-admin-webapps-6.0.33-3.11.1
tomcat6-docs-webapp-6.0.33-3.11.1
tomcat6-el-1_0-api-6.0.33-3.11.1
tomcat6-javadoc-6.0.33-3.11.1
tomcat6-jsp-2_1-api-6.0.33-3.11.1
tomcat6-lib-6.0.33-3.11.1
tomcat6-servlet-2_5-api-6.0.33-3.11.1
tomcat6-webapps-6.0.33-3.11.1


References:

http://support.novell.com/security/cve/CVE-2012-4431.html
http://support.novell.com/security/cve/CVE-2012-4534.html
https://bugzilla.novell.com/794548


< Previous Next >
This Thread
  • No further messages