Mailinglist Archive: opensuse-updates (94 mails)

< Previous Next >
openSUSE-SU-2012:1532-1: moderate: lighttpd
openSUSE Security Update: lighttpd
______________________________________________________________________________

Announcement ID: openSUSE-SU-2012:1532-1
Rating: moderate
References: #790258
Cross-References: CVE-2012-5533
Affected Products:
openSUSE 12.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:


- Fixing bnc#790258 CVE-2012-5533: Denial of Service via
specially-crafted HTTP header. Added patches:
0001-Fix-DoS-in-header-value-split-reported-by-Jesse-Sipp.pa
tch 0001-remove-whitespace-at-end-of-header-keys.patch


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.2:

zypper in -t patch openSUSE-2012-801

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.2 (i586 x86_64):

lighttpd-1.4.31-4.4.2
lighttpd-debuginfo-1.4.31-4.4.2
lighttpd-debugsource-1.4.31-4.4.2
lighttpd-mod_cml-1.4.31-4.4.2
lighttpd-mod_cml-debuginfo-1.4.31-4.4.2
lighttpd-mod_geoip-1.4.31-4.4.2
lighttpd-mod_geoip-debuginfo-1.4.31-4.4.2
lighttpd-mod_magnet-1.4.31-4.4.2
lighttpd-mod_magnet-debuginfo-1.4.31-4.4.2
lighttpd-mod_mysql_vhost-1.4.31-4.4.2
lighttpd-mod_mysql_vhost-debuginfo-1.4.31-4.4.2
lighttpd-mod_rrdtool-1.4.31-4.4.2
lighttpd-mod_rrdtool-debuginfo-1.4.31-4.4.2
lighttpd-mod_trigger_b4_dl-1.4.31-4.4.2
lighttpd-mod_trigger_b4_dl-debuginfo-1.4.31-4.4.2
lighttpd-mod_webdav-1.4.31-4.4.2
lighttpd-mod_webdav-debuginfo-1.4.31-4.4.2


References:

http://support.novell.com/security/cve/CVE-2012-5533.html
https://bugzilla.novell.com/790258


< Previous Next >
This Thread
  • No further messages