Mailinglist Archive: opensuse-updates (56 mails)

< Previous Next >
openSUSE-SU-2012:0884-1: moderate: gypsy (CVE-2011-0523, CVE-2011-0524)
openSUSE Security Update: gypsy (CVE-2011-0523, CVE-2011-0524)
______________________________________________________________________________

Announcement ID: openSUSE-SU-2012:0884-1
Rating: moderate
References: #666839
Cross-References: CVE-2011-0523 CVE-2011-0524
Affected Products:
openSUSE 12.1
openSUSE 11.4
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:


The following changes have been made:
- Add gypsy-CVE-2011-0523.patch: add config file to
restrict the files that can be read. Fix CVE-2011-0523
and bnc#666839.
- Add gypsy-CVE-2011-0524.patch: use snprintf() to avoid
buffer overflows. Fix CVE-2011-0524 and bnc#666839.
- Add gnome-common BuildRequires and call to
gnome-autogen.sh for gypsy-CVE-2011-0523.patch, since it
touches the build system.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.1:

zypper in -t patch openSUSE-2012-394

- openSUSE 11.4:

zypper in -t patch openSUSE-2012-394

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.1 (i586 x86_64):

gypsy-0.8-7.4.1
gypsy-debuginfo-0.8-7.4.1
gypsy-debugsource-0.8-7.4.1
libgypsy-devel-0.8-7.4.1
libgypsy0-0.8-7.4.1
libgypsy0-debuginfo-0.8-7.4.1

- openSUSE 11.4 (i586 x86_64):

gypsy-0.8-5.1
gypsy-debuginfo-0.8-5.1
gypsy-debugsource-0.8-5.1
libgypsy-devel-0.8-5.1
libgypsy0-0.8-5.1
libgypsy0-debuginfo-0.8-5.1


References:

http://support.novell.com/security/cve/CVE-2011-0523.html
http://support.novell.com/security/cve/CVE-2011-0524.html
https://bugzilla.novell.com/666839


< Previous Next >
This Thread
  • No further messages