Mailinglist Archive: opensuse-updates (53 mails)

< Previous Next >
openSUSE-RU-2012:0320-1: moderate: logrotate: Make it more robust
openSUSE Recommended Update: logrotate: Make it more robust
______________________________________________________________________________

Announcement ID: openSUSE-RU-2012:0320-1
Rating: moderate
References: #677335
Affected Products:
openSUSE 11.4
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

In order to make logrotate more robust against manipulated
log directories logrotate was changed to

* add a "su" config option which makes logrotate run
partially as the specified user
* run external helpers like log file compressors as the
user configured with the "su" option
* issue a warning for log directories writable by non-root
users
* not follow symlinks when rotating logs


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch logrotate-5744

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64):

logrotate-3.7.9-6.9.1


References:

http://support.novell.com/security/cve/CVE-2011-1550.html
https://bugzilla.novell.com/677335


< Previous Next >
This Thread
  • No further messages