Mailinglist Archive: opensuse-updates (41 mails)

< Previous Next >
openSUSE-SU-2012:0103-1: moderate: Fixed apache tomcat hash collision vulnerability (CVE-2011-4858)
openSUSE Security Update: Fixed apache tomcat hash collision vulnerability
(CVE-2011-4858)
______________________________________________________________________________

Announcement ID: openSUSE-SU-2012:0103-1
Rating: moderate
References: #712784 #727543
Cross-References: CVE-2011-4858
Affected Products:
openSUSE 11.4
openSUSE 11.3
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available.

Description:

The apache tomcat was vulnerable to a hash collision attack
which allowed remote attackers to mount DoS attacks.
CVE-2011-4858 has been assigned to this issue.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch tomcat6-5619

- openSUSE 11.3:

zypper in -t patch tomcat6-5619

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (noarch):

tomcat6-6.0.32-7.12.1
tomcat6-admin-webapps-6.0.32-7.12.1
tomcat6-docs-webapp-6.0.32-7.12.1
tomcat6-el-1_0-api-6.0.32-7.12.1
tomcat6-javadoc-6.0.32-7.12.1
tomcat6-jsp-2_1-api-6.0.32-7.12.1
tomcat6-lib-6.0.32-7.12.1
tomcat6-servlet-2_5-api-6.0.32-7.12.1
tomcat6-webapps-6.0.32-7.12.1

- openSUSE 11.3 (noarch):

tomcat6-6.0.24-5.16.1
tomcat6-admin-webapps-6.0.24-5.16.1
tomcat6-docs-webapp-6.0.24-5.16.1
tomcat6-el-1_0-api-6.0.24-5.16.1
tomcat6-javadoc-6.0.24-5.16.1
tomcat6-jsp-2_1-api-6.0.24-5.16.1
tomcat6-lib-6.0.24-5.16.1
tomcat6-servlet-2_5-api-6.0.24-5.16.1
tomcat6-webapps-6.0.24-5.16.1


References:

http://support.novell.com/security/cve/CVE-2011-4858.html
https://bugzilla.novell.com/712784
https://bugzilla.novell.com/727543


< Previous Next >
This Thread
  • No further messages