Mailinglist Archive: opensuse-updates (41 mails)

< Previous Next >
openSUSE-SU-2012:0100-1: moderate: icu (CVE-2011-4599, CVE-2010-4409)
openSUSE Security Update: icu (CVE-2011-4599, CVE-2010-4409)
______________________________________________________________________________

Announcement ID: openSUSE-SU-2012:0100-1
Rating: moderate
References: #657910 #736146
Cross-References: CVE-2010-4409 CVE-2011-4599
Affected Products:
openSUSE 11.4
openSUSE 11.3
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

Specially crafted strings could cause a buffer overflow in
icu (CVE-2011-4599).

An integer overflow in the getSymbol() function could crash
applications using icu (CVE-2010-4409)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch icu-5658

- openSUSE 11.3:

zypper in -t patch icu-5658

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64):

icu-4.4.2-4.5.1
icu-data-4.4.2-4.5.1
libicu-4.4.2-4.5.1
libicu-devel-4.4.2-4.5.1
libicu-doc-4.4.2-4.5.1

- openSUSE 11.4 (x86_64):

libicu-32bit-4.4.2-4.5.1
libicu-devel-32bit-4.4.2-4.5.1

- openSUSE 11.3 (i586 x86_64):

icu-4.2-7.3.1
icu-data-4.2-7.3.1
libicu-4.2-7.3.1
libicu-devel-4.2-7.3.1
libicu-doc-4.2-7.3.1

- openSUSE 11.3 (x86_64):

libicu-32bit-4.2-7.3.1
libicu-devel-32bit-4.2-7.3.1


References:

http://support.novell.com/security/cve/CVE-2010-4409.html
http://support.novell.com/security/cve/CVE-2011-4599.html
https://bugzilla.novell.com/657910
https://bugzilla.novell.com/736146


< Previous Next >
This Thread
  • No further messages