Mailinglist Archive: opensuse-updates (12 mails)

< Previous Next >
openSUSE-SU-2011:1318-1: moderate: dhcp
openSUSE Security Update: dhcp
______________________________________________________________________________

Announcement ID: openSUSE-SU-2011:1318-1
Rating: moderate
References: #735610
Cross-References: CVE-2011-4539
Affected Products:
openSUSE 11.4
openSUSE 11.3
______________________________________________________________________________

An update that fixes one vulnerability is now available. It
includes two new package versions.

Description:

Specially crafted requests could crash dhcpd if the server
used regular expressions for matching (CVE-2011-4539).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch dhcp-5532

- openSUSE 11.3:

zypper in -t patch dhcp-5532

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64) [New Version: 4.2.1]:

dhcp-4.2.1-0.11.1
dhcp-client-4.2.1-0.11.1
dhcp-devel-4.2.1-0.11.1
dhcp-doc-4.2.1-0.11.1
dhcp-relay-4.2.1-0.11.1
dhcp-server-4.2.1-0.11.1

- openSUSE 11.3 (i586 x86_64) [New Version: 4.1.2.ESV.1]:

dhcp-4.1.2.ESV.1-0.12.1
dhcp-client-4.1.2.ESV.1-0.12.1
dhcp-devel-4.1.2.ESV.1-0.12.1
dhcp-doc-4.1.2.ESV.1-0.12.1
dhcp-relay-4.1.2.ESV.1-0.12.1
dhcp-server-4.1.2.ESV.1-0.12.1


References:

http://support.novell.com/security/cve/CVE-2011-4539.html
https://bugzilla.novell.com/735610


< Previous Next >
This Thread
  • No further messages