Mailinglist Archive: opensuse-updates (36 mails)

< Previous Next >
openSUSE-SU-2011:1119-1: libqt4
openSUSE Security Update: libqt4
______________________________________________________________________________

Announcement ID: openSUSE-SU-2011:1119-1
Rating: low
References: #592962 #637275 #643848 #668210 #669604 #714984

Cross-References: CVE-2011-3193 CVE-2011-3194
Affected Products:
openSUSE 11.3
______________________________________________________________________________

An update that solves two vulnerabilities and has four
fixes is now available.

Description:

Specially crafted font files could cause a single byte heap
based buffer overflow (CVE-2011-3193).

Specially crafted grey scale images could cause a heap
based buffer overflow (CVE-2011-3194).

The update also fixes the following non-security bugs:
- fix QFileDialog not showing system files (bnc#669604)
- fix font fallback handling (bnc#643848)
- add support for postgresql 8.3 and 9 (bnc#668210)
- Path added: bnc#592962 - Set application icon.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.3:

zypper in -t patch libQtWebKit-devel-5125

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.3 (i586 x86_64):

libQtWebKit-devel-4.6.3-2.5.1
libQtWebKit4-4.6.3-2.5.1
libqt4-4.6.3-2.5.1
libqt4-devel-4.6.3-2.5.1
libqt4-devel-doc-4.6.3-2.5.1
libqt4-qt3support-4.6.3-2.5.1
libqt4-sql-4.6.3-2.5.1
libqt4-sql-mysql-4.6.3-2.5.1
libqt4-sql-postgresql-4.6.3-2.5.1
libqt4-sql-sqlite-4.6.3-2.5.1
libqt4-sql-unixODBC-4.6.3-2.5.1
libqt4-x11-4.6.3-2.5.1
qt4-x11-tools-4.6.3-2.5.1

- openSUSE 11.3 (x86_64):

libQtWebKit4-32bit-4.6.3-2.5.1
libqt4-32bit-4.6.3-2.5.1
libqt4-qt3support-32bit-4.6.3-2.5.1
libqt4-sql-32bit-4.6.3-2.5.1
libqt4-sql-mysql-32bit-4.6.3-2.5.1
libqt4-sql-postgresql-32bit-4.6.3-2.5.1
libqt4-sql-sqlite-32bit-4.6.3-2.5.1
libqt4-sql-unixODBC-32bit-4.6.3-2.5.1
libqt4-x11-32bit-4.6.3-2.5.1

- openSUSE 11.3 (noarch):

libqt4-devel-doc-data-4.6.3-2.5.1


References:

http://support.novell.com/security/cve/CVE-2011-3193.html
http://support.novell.com/security/cve/CVE-2011-3194.html
https://bugzilla.novell.com/592962
https://bugzilla.novell.com/637275
https://bugzilla.novell.com/643848
https://bugzilla.novell.com/668210
https://bugzilla.novell.com/669604
https://bugzilla.novell.com/714984


< Previous Next >
This Thread
  • No further messages