Mailinglist Archive: opensuse-updates (67 mails)

< Previous Next >
openSUSE-SU-2011:0482-1 (moderate): webkit: security update
openSUSE Security Update: webkit: security update
______________________________________________________________________________

Announcement ID: openSUSE-SU-2011:0482-1
Rating: moderate
References: #617401
Cross-References: CVE-2010-2441 CVE-2010-2901 CVE-2010-4042
CVE-2010-4492 CVE-2010-4493 CVE-2010-4578
CVE-2011-0482 CVE-2011-0778
Affected Products:
openSUSE 11.3
openSUSE 11.2
______________________________________________________________________________

An update that fixes 8 vulnerabilities is now available. It
includes one version update.

Description:

This version upgrade of webkit to 1.2.7 fixes the
following bugs:
- CVE-2010-2441: CVSS v2 Base Score: 4.3
(AV:N/AC:M/Au:N/C:P/I:N/A:N): Permissions, Privileges,
and Access Control (CWE-264)
- CVE-2010-2901: CVSS v2 Base Score: 3.7
(AV:L/AC:H/Au:N/C:P/I:P/A:P): Buffer Errors (CWE-119)
- CVE-2010-4042: CVSS v2 Base Score: 3.7
(AV:L/AC:H/Au:N/C:P/I:P/A:P): Input Validation (CWE-20)
- CVE-2010-4492: CVSS v2 Base Score: 7.5
(AV:N/AC:L/Au:N/C:P/I:P/A:P): Resource Management Errors
(CWE-399)
- CVE-2010-4493: CVSS v2 Base Score: 3.7
(AV:L/AC:H/Au:N/C:P/I:P/A:P): Resource Management Errors
(CWE-399)
- CVE-2010-4578: CVSS v2 Base Score: 3.7
(AV:L/AC:H/Au:N/C:P/I:P/A:P): Input Validation (CWE-20)
- CVE-2011-0482: CVSS v2 Base Score: 3.7
(AV:L/AC:H/Au:N/C:P/I:P/A:P): Numeric Errors (CWE-189)
- CVE-2011-0778: CVSS v2 Base Score: 3.7
(AV:L/AC:H/Au:N/C:P/I:P/A:P): Permissions, Privileges,
and Access Control (CWE-264)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.3:

zypper in -t patch libwebkit-4112

- openSUSE 11.2:

zypper in -t patch libwebkit-4112

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.3 (i586 x86_64) [New Version: 1.2.7]:

libwebkit-1_0-2-1.2.7-0.2.1
libwebkit-devel-1.2.7-0.2.1
webkit-jsc-1.2.7-0.2.1

- openSUSE 11.3 (x86_64) [New Version: 1.2.7]:

libwebkit-1_0-2-32bit-1.2.7-0.2.1

- openSUSE 11.3 (noarch) [New Version: 1.2.7]:

libwebkit-lang-1.2.7-0.2.1

- openSUSE 11.2 (i586 x86_64) [New Version: 1.2.7]:

libwebkit-1_0-2-1.2.7-0.3.1
libwebkit-devel-1.2.7-0.3.1
webkit-jsc-1.2.7-0.3.1

- openSUSE 11.2 (noarch) [New Version: 1.2.7]:

libwebkit-lang-1.2.7-0.3.1


References:

http://support.novell.com/security/cve/CVE-2010-2441.html
http://support.novell.com/security/cve/CVE-2010-2901.html
http://support.novell.com/security/cve/CVE-2010-4042.html
http://support.novell.com/security/cve/CVE-2010-4492.html
http://support.novell.com/security/cve/CVE-2010-4493.html
http://support.novell.com/security/cve/CVE-2010-4578.html
http://support.novell.com/security/cve/CVE-2011-0482.html
http://support.novell.com/security/cve/CVE-2011-0778.html
https://bugzilla.novell.com/617401


< Previous Next >
This Thread
  • No further messages