Mailinglist Archive: opensuse-updates (84 mails)

< Previous Next >
openSUSE-SU-2011:0357-1 (moderate): kbd security update
openSUSE Security Update: kbd security update
______________________________________________________________________________

Announcement ID: openSUSE-SU-2011:0357-1
Rating: moderate
References: #663898
Cross-References: CVE-2011-0460
Affected Products:
openSUSE 11.3
openSUSE 11.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

The kbd init scripted wrote a file to /dev/shm during
shut-down. Since local users may create symlinks there a
malicious user could cause corruption of arbitrary files
(CVE-2011-0460).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.3:

zypper in -t patch kbd-3914

- openSUSE 11.2:

zypper in -t patch kbd-3914

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.3 (i586 x86_64):

kbd-1.14.1-31.3.1

- openSUSE 11.2 (i586 x86_64):

kbd-1.14.1-20.5.1


References:

http://support.novell.com/security/cve/CVE-2011-0460.html
https://bugzilla.novell.com/663898


< Previous Next >
This Thread
  • No further messages