Mailinglist Archive: opensuse-updates (84 mails)

< Previous Next >
openSUSE-SU-2011:0313-1 (critical): moonlight security update
openSUSE Security Update: moonlight security update
______________________________________________________________________________

Announcement ID: openSUSE-SU-2011:0313-1
Rating: critical
References: #667077
Cross-References: CVE-2011-0989 CVE-2011-0990 CVE-2011-0991
CVE-2011-0992
Affected Products:
openSUSE 11.4
openSUSE 11.3
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.
It includes one version update.

Description:

Moonlight was prone to several security problems:

CVE-2011-0989: modification of read-only values via
RuntimeHelpers.InitializeArray CVE-2011-0990: buffer
overflow due to race condition in in Array.FastCopy
CVE-2011-0991: use-after-free due to DynamicMethod
resurrection CVE-2011-0992: information leak due to
improper thread finalization


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch libmoon-devel-4318

- openSUSE 11.3:

zypper in -t patch libmoon-devel-4318

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64) [New Version: 2.4.1]:

libmoon-devel-2.4.1-0.3.1
libmoon0-2.4.1-0.3.1
moonlight-desktop-2.4.1-0.3.1
moonlight-desktop-devel-2.4.1-0.3.1
moonlight-plugin-2.4.1-0.3.1
moonlight-tools-2.4.1-0.3.1
moonlight-web-devel-2.4.1-0.3.1

- openSUSE 11.3 (i586 x86_64) [New Version: 2.4.1]:

libmoon-devel-2.4.1-0.2.1
libmoon0-2.4.1-0.2.1
moonlight-desktop-2.4.1-0.2.1
moonlight-desktop-devel-2.4.1-0.2.1
moonlight-plugin-2.4.1-0.2.1
moonlight-tools-2.4.1-0.2.1
moonlight-web-devel-2.4.1-0.2.1


References:

http://support.novell.com/security/cve/CVE-2011-0989.html
http://support.novell.com/security/cve/CVE-2011-0990.html
http://support.novell.com/security/cve/CVE-2011-0991.html
http://support.novell.com/security/cve/CVE-2011-0992.html
https://bugzilla.novell.com/667077


< Previous Next >
This Thread
  • No further messages