Mailinglist Archive: opensuse-updates (84 mails)

< Previous Next >
openSUSE-SU-2011:0311-1 (important): libvirt security update
openSUSE Security Update: libvirt security update
______________________________________________________________________________

Announcement ID: openSUSE-SU-2011:0311-1
Rating: important
References: #678406
Cross-References: CVE-2011-1146
Affected Products:
openSUSE 11.4
openSUSE 11.3
openSUSE 11.2
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

several API calls did not honor the read-only flag
connections. Attackers could exploit that to modify the
state of the system or potentially execute code
(CVE-2011-1146).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch libvirt-4164

- openSUSE 11.3:

zypper in -t patch libvirt-4164

- openSUSE 11.2:

zypper in -t patch libvirt-4164

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64):

libvirt-0.8.8-0.6.1
libvirt-client-0.8.8-0.6.1
libvirt-devel-0.8.8-0.6.1
libvirt-doc-0.8.8-0.6.1
libvirt-python-0.8.8-0.6.1

- openSUSE 11.3 (i586 x86_64):

libvirt-0.8.1-4.6.2
libvirt-client-0.8.1-4.6.2
libvirt-devel-0.8.1-4.6.2
libvirt-doc-0.8.1-4.6.2
libvirt-python-0.8.1-4.6.2

- openSUSE 11.2 (i586 x86_64):

libvirt-0.7.2-1.1.5.1
libvirt-devel-0.7.2-1.1.5.1
libvirt-doc-0.7.2-1.1.5.1
libvirt-python-0.7.2-1.1.5.1


References:

http://support.novell.com/security/cve/CVE-2011-1146.html
https://bugzilla.novell.com/678406


< Previous Next >
This Thread
  • No further messages