Mailinglist Archive: opensuse-updates (48 mails)

< Previous Next >
openSUSE-SU-2010:0754-1 (critical): java-1_6_0-sun: Security Update to U22
  • From: opensuse-security@xxxxxxxxxxxx
  • Date: Thu, 21 Oct 2010 22:08:26 +0200 (CEST)
  • Message-id: <20101021200826.BB7F4BE47@xxxxxxxxxxxxxx>
openSUSE Security Update: java-1_6_0-sun: Security Update to U22
______________________________________________________________________________

Announcement ID: openSUSE-SU-2010:0754-1
Rating: critical
References: #646073
Cross-References: CVE-2009-3555 CVE-2010-1321 CVE-2010-3541
CVE-2010-3548 CVE-2010-3549 CVE-2010-3550
CVE-2010-3551 CVE-2010-3552 CVE-2010-3553
CVE-2010-3554 CVE-2010-3555 CVE-2010-3556
CVE-2010-3557 CVE-2010-3558 CVE-2010-3559
CVE-2010-3560 CVE-2010-3561 CVE-2010-3562
CVE-2010-3563 CVE-2010-3565 CVE-2010-3566
CVE-2010-3567 CVE-2010-3568 CVE-2010-3569
CVE-2010-3570 CVE-2010-3571 CVE-2010-3572
CVE-2010-3573 CVE-2010-3574
Affected Products:
openSUSE 11.3
openSUSE 11.2
openSUSE 11.1
______________________________________________________________________________

An update that fixes 29 vulnerabilities is now available.
It includes one version update.

Description:

Sun Java 1.6.0 was updated to Security Update U22.

The release notes for this release are on:
http://www.oracle.com/technetwork/java/javase/6u22releasenot
es-176121.html

Security advisory page for this update:
http://www.oracle.com/technetwork/topics/security/javacpuoct
2010-176258.html

Following CVEs are tracked by the update: CVE-2010-3556
CVE-2010-3562 CVE-2010-3565 CVE-2010-3566 CVE-2010-3567
CVE-2010-3571 CVE-2010-3554 CVE-2010-3563 CVE-2010-3568
CVE-2010-3569 CVE-2010-3558 CVE-2010-3552 CVE-2010-3559
CVE-2010-3572 CVE-2010-3553 CVE-2010-3555 CVE-2010-3550
CVE-2010-3570 CVE-2010-3561 CVE-2009-3555 CVE-2010-1321
CVE-2010-3549 CVE-2010-3557 CVE-2010-3541 CVE-2010-3573
CVE-2010-3574 CVE-2010-3548 CVE-2010-3551 CVE-2010-3560


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.3:

zypper in -t patch java-1_6_0-sun-3354

- openSUSE 11.2:

zypper in -t patch java-1_6_0-sun-3354

- openSUSE 11.1:

zypper in -t patch java-1_6_0-sun-3354

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.3 (i586 x86_64) [New Version: 1.6.0.u22]:

java-1_6_0-sun-1.6.0.u22-1.2.1
java-1_6_0-sun-alsa-1.6.0.u22-1.2.1
java-1_6_0-sun-devel-1.6.0.u22-1.2.1
java-1_6_0-sun-jdbc-1.6.0.u22-1.2.1
java-1_6_0-sun-plugin-1.6.0.u22-1.2.1
java-1_6_0-sun-src-1.6.0.u22-1.2.1

- openSUSE 11.2 (i586 x86_64) [New Version: 1.6.0.u22]:

java-1_6_0-sun-1.6.0.u22-1.2.1
java-1_6_0-sun-alsa-1.6.0.u22-1.2.1
java-1_6_0-sun-demo-1.6.0.u22-1.2.1
java-1_6_0-sun-devel-1.6.0.u22-1.2.1
java-1_6_0-sun-jdbc-1.6.0.u22-1.2.1
java-1_6_0-sun-plugin-1.6.0.u22-1.2.1
java-1_6_0-sun-src-1.6.0.u22-1.2.1

- openSUSE 11.1 (i586 x86_64) [New Version: 1.6.0.u22]:

java-1_6_0-sun-1.6.0.u22-1.2.1
java-1_6_0-sun-alsa-1.6.0.u22-1.2.1
java-1_6_0-sun-devel-1.6.0.u22-1.2.1
java-1_6_0-sun-jdbc-1.6.0.u22-1.2.1
java-1_6_0-sun-plugin-1.6.0.u22-1.2.1
java-1_6_0-sun-src-1.6.0.u22-1.2.1


References:

http://support.novell.com/security/cve/CVE-2009-3555.html
http://support.novell.com/security/cve/CVE-2010-1321.html
http://support.novell.com/security/cve/CVE-2010-3541.html
http://support.novell.com/security/cve/CVE-2010-3548.html
http://support.novell.com/security/cve/CVE-2010-3549.html
http://support.novell.com/security/cve/CVE-2010-3550.html
http://support.novell.com/security/cve/CVE-2010-3551.html
http://support.novell.com/security/cve/CVE-2010-3552.html
http://support.novell.com/security/cve/CVE-2010-3553.html
http://support.novell.com/security/cve/CVE-2010-3554.html
http://support.novell.com/security/cve/CVE-2010-3555.html
http://support.novell.com/security/cve/CVE-2010-3556.html
http://support.novell.com/security/cve/CVE-2010-3557.html
http://support.novell.com/security/cve/CVE-2010-3558.html
http://support.novell.com/security/cve/CVE-2010-3559.html
http://support.novell.com/security/cve/CVE-2010-3560.html
http://support.novell.com/security/cve/CVE-2010-3561.html
http://support.novell.com/security/cve/CVE-2010-3562.html
http://support.novell.com/security/cve/CVE-2010-3563.html
http://support.novell.com/security/cve/CVE-2010-3565.html
http://support.novell.com/security/cve/CVE-2010-3566.html
http://support.novell.com/security/cve/CVE-2010-3567.html
http://support.novell.com/security/cve/CVE-2010-3568.html
http://support.novell.com/security/cve/CVE-2010-3569.html
http://support.novell.com/security/cve/CVE-2010-3570.html
http://support.novell.com/security/cve/CVE-2010-3571.html
http://support.novell.com/security/cve/CVE-2010-3572.html
http://support.novell.com/security/cve/CVE-2010-3573.html
http://support.novell.com/security/cve/CVE-2010-3574.html
https://bugzilla.novell.com/646073


< Previous Next >
This Thread
  • No further messages