Mailinglist Archive: opensuse-updates (48 mails)

< Previous Next >
openSUSE-SU-2010:0732-1 (moderate): OpenOffice_org security update
  • From: opensuse-security@xxxxxxxxxxxx
  • Date: Fri, 15 Oct 2010 22:08:17 +0200 (CEST)
  • Message-id: <20101015200817.391B3BE45@xxxxxxxxxxxxxx>
openSUSE Security Update: OpenOffice_org security update
______________________________________________________________________________

Announcement ID: openSUSE-SU-2010:0732-1
Rating: moderate
References: #629085
Cross-References: CVE-2010-2935 CVE-2010-2936
Affected Products:
openSUSE 11.3
openSUSE 11.2
openSUSE 11.1
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

Specially crafted ppt files could cause a heap based buffer
overflow in OpenOffice_org Impress. Attackers could exploit
that to crash OpenOffice_org or potentially even execute
arbitrary code (CVE-2010-2935, CVE-2010-2936).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.3:

zypper in -t patch OpenOffice_org-draw-3081

- openSUSE 11.2:

zypper in -t patch OpenOffice_org-draw-3081

- openSUSE 11.1:

zypper in -t patch OpenOffice_org-draw-3081

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.3 (i586 x86_64):

OpenOffice_org-draw-3.2.1.4-2.1.1
OpenOffice_org-impress-3.2.1.4-2.1.1
OpenOffice_org-impress-devel-3.2.1.4-2.1.1
OpenOffice_org-impress-l10n-prebuilt-3.2.1.4-2.1.1
OpenOffice_org-libs-gui-3.2.1.4-2.1.1
OpenOffice_org-libs-gui-devel-3.2.1.4-2.1.1
OpenOffice_org-libs-gui-l10n-prebuilt-3.2.1.4-2.1.1

- openSUSE 11.2 (i586 x86_64):

OpenOffice_org-draw-3.1.1.4-1.2.2
OpenOffice_org-impress-3.1.1.4-1.2.2
OpenOffice_org-impress-devel-3.1.1.4-1.2.2
OpenOffice_org-impress-l10n-prebuilt-3.1.1.4-1.2.2
OpenOffice_org-libs-gui-3.1.1.4-1.1.8.1
OpenOffice_org-libs-gui-devel-3.1.1.4-1.1.8.1
OpenOffice_org-libs-gui-l10n-prebuilt-3.1.1.4-1.1.8.1

- openSUSE 11.1 (i586 ppc x86_64):

OpenOffice_org-draw-3.0.0.9-1.13.1
OpenOffice_org-impress-3.0.0.9-1.13.1
OpenOffice_org-impress-devel-3.0.0.9-1.13.1
OpenOffice_org-impress-l10n-prebuilt-3.0.0.9-1.13.1
OpenOffice_org-libs-gui-3.0.0.9-1.13.1
OpenOffice_org-libs-gui-devel-3.0.0.9-1.13.1
OpenOffice_org-libs-gui-l10n-prebuilt-3.0.0.9-1.13.1


References:

http://support.novell.com/security/cve/CVE-2010-2935.html
http://support.novell.com/security/cve/CVE-2010-2936.html
https://bugzilla.novell.com/629085


< Previous Next >
This Thread
  • No further messages