Mailinglist Archive: opensuse-updates (72 mails)

< Previous Next >
openSUSE-RU-2010:0472-1 (low): perl: This update fixes a crash caused by the use of constants.
  • From: maintenance@xxxxxxxxxxxx
  • Date: Thu, 5 Aug 2010 17:08:16 +0200 (CEST)
  • Message-id: <20100805150817.3520EBE29@xxxxxxxxxxxxxx>
openSUSE Recommended Update: perl: This update fixes a crash caused by the
use of constants.
______________________________________________________________________________

Announcement ID: openSUSE-RU-2010:0472-1
Rating: low
References: #621856 #624628
Affected Products:
openSUSE 11.3
______________________________________________________________________________

An update that has two recommended fixes can now be
installed.

Description:

If a constant is defined with the 'use constant' pragma,
perl may crash later on when the constant is used as
function argument (like in a print statement). Also, a bug
in the h2ph translator was fixed that led to spurious
warnings about _h2ph_pre.ph if 'perl -w' was used.


Patch Instructions:

To install this openSUSE Recommended Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.3:

zypper in -t patch perl-2828

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.3 (i586 src x86_64):

perl-5.12.1-2.1.1

- openSUSE 11.3 (i586 x86_64):

perl-base-5.12.1-2.1.1

- openSUSE 11.3 (x86_64):

perl-32bit-5.12.1-2.1.1
perl-base-32bit-5.12.1-2.1.1

- openSUSE 11.3 (noarch):

perl-doc-5.12.1-2.1.1


References:

https://bugzilla.novell.com/621856
https://bugzilla.novell.com/624628


< Previous Next >
This Thread
  • No further messages