Mailinglist Archive: opensuse-updates (57 mails)

< Previous Next >
openSUSE-SU-2010:0427-1 (moderate): openldap: fixed MODRDN DoS, replicating inconsistencies and \0 character-DoS
  • From: opensuse-security@xxxxxxxxxxxx
  • Date: Sat, 24 Jul 2010 04:08:11 +0200 (CEST)
  • Message-id: <20100724020812.3C3B8BE29@xxxxxxxxxxxxxx>
openSUSE Security Update: openldap: fixed MODRDN DoS, replicating
inconsistencies and \0 character-DoS
______________________________________________________________________________

Announcement ID: openSUSE-SU-2010:0427-1
Rating: moderate
References: #612430
Cross-References: CVE-2010-0211 CVE-2010-0212
Affected Products:
openSUSE 11.0
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

The following issues have been fixed in OpenLDAP: specially
crafted MODRDN operations can crash the OpenLDAP server
(CVE-2010-0211 and CVE-2010-0212).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.0:

zypper in -t patch openldap2-2727

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.0 (i586 ppc src x86_64):

openldap2-2.4.9-7.8
openldap2-client-2.4.9-7.8

- openSUSE 11.0 (i586 ppc x86_64):

openldap2-back-meta-2.4.9-7.8
openldap2-back-perl-2.4.9-7.8
openldap2-devel-2.4.9-7.8

- openSUSE 11.0 (x86_64):

openldap2-client-32bit-2.4.9-7.8
openldap2-devel-32bit-2.4.9-7.8

- openSUSE 11.0 (ppc):

openldap2-client-64bit-2.4.9-7.8
openldap2-devel-64bit-2.4.9-7.8


References:

http://support.novell.com/security/cve/CVE-2010-0211.html
http://support.novell.com/security/cve/CVE-2010-0212.html
https://bugzilla.novell.com/612430


< Previous Next >
This Thread
  • No further messages