Mailinglist Archive: opensuse-updates (57 mails)

< Previous Next >
openSUSE-SU-2010:0423-1 (moderate): vte security update
  • From: opensuse-security@xxxxxxxxxxxx
  • Date: Thu, 22 Jul 2010 19:08:24 +0200 (CEST)
  • Message-id: <20100722170824.A73DCBE29@xxxxxxxxxxxxxx>
openSUSE Security Update: vte security update
______________________________________________________________________________

Announcement ID: openSUSE-SU-2010:0423-1
Rating: moderate
References: #621097
Cross-References: CVE-2010-2713
Affected Products:
openSUSE 11.3
openSUSE 11.2
______________________________________________________________________________

An update that fixes one vulnerability is now available. It
includes one version update.

Description:

VTE was vulnerable to an old title set+query attack which
could be used by remote attackers to execute arbitrary code
(CVE-2010-2713).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.3:

zypper in -t patch vte-2729

- openSUSE 11.2:

zypper in -t patch vte-2729

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.3 (i586 src x86_64):

vte-0.24.1-2.1.1

- openSUSE 11.3 (i586 x86_64):

vte-devel-0.24.1-2.1.1

- openSUSE 11.3 (noarch):

vte-lang-0.24.1-2.1.1

- openSUSE 11.2 (i586 src x86_64) [New Version: 0.22.5]:

vte-0.22.5-0.2.1

- openSUSE 11.2 (i586 x86_64) [New Version: 0.22.5]:

vte-devel-0.22.5-0.2.1

- openSUSE 11.2 (noarch) [New Version: 0.22.5]:

vte-lang-0.22.5-0.2.1


References:

http://support.novell.com/security/cve/CVE-2010-2713.html
https://bugzilla.novell.com/621097


< Previous Next >
This Thread
  • No further messages