Mailinglist Archive: opensuse-updates (94 mails)

< Previous Next >
openSUSE-SU-2010:0183-1 (moderate): irssi security update
  • From: opensuse-security@xxxxxxxxxxxx
  • Date: Thu, 29 Apr 2010 15:08:14 +0200 (CEST)
  • Message-id: <20100429130814.4A536BE13@xxxxxxxxxxxxxx>
openSUSE Security Update: irssi security update
______________________________________________________________________________

Announcement ID: openSUSE-SU-2010:0183-1
Rating: moderate
References: #596005
Cross-References: CVE-2010-1155 CVE-2010-1156
Affected Products:
openSUSE 11.2
openSUSE 11.1
openSUSE 11.0
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

irssi did not check the identity information of a remote
hosts's certificate. Attackers could exploit that for a
man-in-the-middle attack (CVE-2010-1155).

irssi could crash if someone changed nick while the victim
was leaving the channel (CVE-2010-1156).


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.2:

zypper in -t patch irssi-2368

- openSUSE 11.1:

zypper in -t patch irssi-2368

- openSUSE 11.0:

zypper in -t patch irssi-2368

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.2 (i586 src x86_64):

irssi-0.8.13-2.2.1

- openSUSE 11.2 (i586 x86_64):

irssi-devel-0.8.13-2.2.1

- openSUSE 11.1 (i586 ppc src x86_64):

irssi-0.8.12-30.71.1

- openSUSE 11.1 (i586 ppc x86_64):

irssi-devel-0.8.12-30.71.1

- openSUSE 11.0 (i586 ppc src x86_64):

irssi-0.8.12-49.4

- openSUSE 11.0 (i586 ppc x86_64):

irssi-devel-0.8.12-49.4


References:

http://support.novell.com/security/cve/CVE-2010-1155.html
http://support.novell.com/security/cve/CVE-2010-1156.html
https://bugzilla.novell.com/596005


< Previous Next >
This Thread
  • No further messages