Mailinglist Archive: opensuse-updates (94 mails)

< Previous Next >
openSUSE-SU-2010:0115-1 (low): gimp: fix for integer overflow vulnerability
  • From: opensuse-security@xxxxxxxxxxxx
  • Date: Wed, 14 Apr 2010 17:08:22 +0200 (CEST)
  • Message-id: <20100414150822.8833CBE13@xxxxxxxxxxxxxx>
openSUSE Security Update: gimp: fix for integer overflow vulnerability
______________________________________________________________________________

Announcement ID: openSUSE-SU-2010:0115-1
Rating: low
References: #555144 #555166
Cross-References: CVE-2009-1570 CVE-2009-3909
Affected Products:
openSUSE 11.2
openSUSE 11.1
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.
It includes one version update.

Description:

Integer overflows in the BMP and PSD plug-ins potentially
allowed attackers to execute arbitrary code on the victim's
system by tricking the victim to open specially crafted
files (CVE-2009-1570, CVE-2009-3909).

Gimp was updated to to version 2.6.8 which fixes those
issues.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.2:

zypper in -t patch gimp-2160

- openSUSE 11.1:

zypper in -t patch gimp-2151

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.2 (i586 src x86_64) [New Version: 2.6.8]:

gimp-2.6.8-1.1.1

- openSUSE 11.2 (i586 x86_64) [New Version: 2.6.8]:

gimp-branding-upstream-2.6.8-1.1.1
gimp-devel-2.6.8-1.1.1
gimp-help-browser-2.6.8-1.1.1
gimp-plugins-python-2.6.8-1.1.1

- openSUSE 11.2 (noarch) [New Version: 2.6.8]:

gimp-lang-2.6.8-1.1.1

- openSUSE 11.1 (i586 ppc src x86_64):

gimp-2.6.2-2.19.1

- openSUSE 11.1 (i586 ppc x86_64):

gimp-branding-upstream-2.6.2-2.19.1
gimp-devel-2.6.2-2.19.1
gimp-doc-2.6.2-2.19.1
gimp-lang-2.6.2-2.19.1
gimp-plugins-python-2.6.2-2.19.1


References:

http://support.novell.com/security/cve/CVE-2009-1570.html
http://support.novell.com/security/cve/CVE-2009-3909.html
https://bugzilla.novell.com/555144
https://bugzilla.novell.com/555166


< Previous Next >
This Thread
  • No further messages