Mailinglist Archive: opensuse-softwaremgmt (17 mails)

< Previous Next >
Re: [softwaremgmt] What is wrong with softwaremgmt in 11.0. ¿SVN status?
  • From: Stanislav Visnovsky <visnov@xxxxxxx>
  • Date: Tue, 2 Sep 2008 09:43:09 +0200
  • Message-id: <200809020943.09628.visnov@xxxxxxx>
Dňa Friday 22 August 2008 18:04:11 Christian Morales Vega ste napísal:
I'm going to try to list all the problems the current software
management stack from openSUSE 11.0 has right now. All of them are
because some parts ignore repository priorities and/or the "don't
change vendor" rule.
At http://lists.opensuse.org/opensuse-softwaremgmt/2008-07/msg00004.html
and http://lists.opensuse.org/opensuse-softwaremgmt/2008-07/msg00005.html
the problem was somehow discussed, but I don't know if there are plans
to update the stack in 11.0, if the changes will be released only in
11.1 or if there are changes at all.
Like discussed in the Jano Kupec threads "zyper lu" needs changes. The
thing is it isn't a big problem since you can just ignore the fact
that there exists a "lu" option... but there are derivated problem
that are a lot more important. I don't know if they use the same code
path, in which case a single fix would be needed or if a differtent
patch for every problem is needed.

1- Installation of packages from YaST QT (and GTK?) software management
module. VideoLAN repo provides libffmpeg0-0.4.9.13782-1.2 while Packman
provides libffmpeg0-0.4.9svn-20080818.pm.0. I have Packman with a
higher priority than VideoLAN.
Now "zypper in libffmpeg0" will try to install the Packman version.
That's correct. But if I try to install it through YaST...
I left-click over the package, right click on it and select "Install".
Everything correct, isn't? Well no because it has selected the
VideoLAN version since "0.4.9.13782" is higher (somehow...) than
"0.4.9svn-20080818". The worse thing is that I will not notice it if I
don't manually go to the "Versions" tab.
So *everytime* I install something from YaST I must go to the Versions
tab to check the version selected is the one I want.

I assume libffmpeg0 is not installed on your system. In that case, the tools
should behave consistently and I consider this to be a bug.


2- Update of packages through YaST QT (and GTK?) software management
module. "zypper up -t package" will correctly update my system. But if I go
to YaST and select Package->All Packages->Update if newer version
available it will try to install newer versions even if they change
vendor and/or are in repositories with a lower priority.

A recurrent problem here is with multimedia. If you go to the forums
you will see people complaining that after an update they can no
longer see MPEG-4 ASP videos. They first install the Packman packages
and all is good, since Packman has his own vendor string an update
should never change to packages from openSUSE (that don't support
patented codecs) or VideoLAN (that don't play nice mixed with Packman
ones). But since the updater applet and YaST ignore the vendor string
theirs systems end with a mix of multimedia packages from VideoLAN,
Packman and openSUSE... and they must reinstall the Packman packages
again.

I'm not sure what to do about this. It is clear that you expect 'Update all
packages in the list" and 'zypper up -t package' to behave the same, but in
fact there is no indication that they are (and as Jano explained in the bug,
they seems to use different algorithm to determine the result).


3- KDE updater applet
Exactly the same problem that '2'.

The updater is calling zypper directly, so it should behave consistent with
zypper.


4- zypper dup
It looks at vendor strings and doesn't changes between vendors, but it
ignores repository priorities. Not a big problem right now, but I
would like to have a fix for 11.0 before people starts updating to
11.1.

Well, zypper dup is not a "official" way to upgrade from 11.0 to 11.1. You
might be lucky, but that's it (but if it does not work, it is always
interesting to hear about that, so we can try to fix the issue).



So, are all of them just a single thing? A single fix in libzypp will
make zypper, updater applet and YaST work correctly or I should open a
different bug report for each of them? Is this fix already in SVN
versions? There are plans of a fix for 11.0?

In my opinion:
- '1' isn't a big problem, can wait.
- '3' (and perhaps '2') NEEDS a fix for 11.0. Isn't just an
improvement, it's a bug. Right now the updater applet is totally
unusable. I can ignore "zypper lu" and just use "zypper up", but with
the applet I can't ignore the problem... "zypper lu" is the only
option available.
- '4' should be fixed for 11.0 before 11.1 is released.

I'm worried about '2' and '3' since bug #402770 was closed with
WONTFIX (and '1' is also similar).

Not sure if we are able to address the issues, as they might be very deep in
the stack and might result in unpredicable results.

Stano

--
To unsubscribe, e-mail: opensuse-softwaremgmt+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-softwaremgmt+help@xxxxxxxxxxxx

< Previous Next >
List Navigation