Mailinglist Archive: opensuse-security (363 mails)

< Previous Next >
AW: [suse-security] Amavis / Sendmail Problem
  • From: "Ulrich Roth" <Roth@xxxxxxxxx>
  • Date: Thu, 12 Jun 2003 11:26:53 +0200
  • Message-id: <047D33E9F294624A972F6A6325C993C204A641@xxxxxxxxxxxxxxxxxxxxxxxxxx>
Hi Uwe,

> I'm running a SuSE 7.2 as a Mail-Server. Since my last
> OnlineUpdate, which updated sendmail, I have the problem,
> that amavis is not started anymore.
> "rcamavis status" tells me "amavis:OK",
> but the following thing is in the /var/log/boot.msg
>
> Starting virus-scanning for sendmail
> (amavis)<notice>startproc: execve (/usr/sbin/amavis-milter) [
/usr/sbin/amavis-milter -p local:/var/run/amavis.sock failed ], [ > PWD=/ BOOT_FILE=/boot/vmlinuz HOSTNAME=bart
> CONSOLE=/dev/console PREVLEVEL=N AUTOBOOT=YES
> MACHTYPE=i386-suse-linux LINES=25 SHLVL=2 COLUMNS=80
> BOOT_IMAGE=linux SHELL=/bin/bash HOSTTYPE=i386 OSTYPE=linux
> HOME=/ TERM=linux PATH=/sbin:/bin:/usr/sbin:/usr/bin
> RUNLEVEL=3 INIT_VERSION=sysvinit-2.78 _=/sbin/startproc
> DAEMON=/usr/sbin/amavis-milter ]
> done
>
> Does anybody have a clue what happened there? I use Sophos
> sweep for scanning and it works. I even checked
> /usr/sbin/amavis for changes but everything looks perfect.
It looks like the file /var/run/amavis.sock can't be created (I assume because
of missing write permissions, but don't ask me why they are missing).
Nevertheless amavis seems to start up and run.
If I remember well I had a similar problem with sendmail in some other SuSE
distro. So I changed the write permissions, but then I got another error message
that this directory is world writeable and therefore some other thing didn't work.
Bye
Uli
--
Ulrich Roth
IMPACT Business & Technology Consulting GmbH
Im Mediapark 8 / K├ÂlnTurm
D-50670 Koeln
Phone +49-221-93 70 80-29
Fax +49-221-93 70 80-15
E-Mail: roth@xxxxxxxxx

< Previous Next >
This Thread
Follow Ups