Mailinglist Archive: opensuse-security (616 mails)

< Previous Next >
Re: [suse-security] SuSE Security Announcement: mod_php/mod_php4 (SuSE-SA:2002:007)
  • From: Bob Vickers <bobv@xxxxxxxxxxxxx>
  • Date: Fri, 1 Mar 2002 10:12:36 +0000 (GMT)
  • Message-id: <Pine.OSF.4.44.0203011001270.1149-100000@xxxxxxxxxxxxxxxxxxxxx>
Roman,

I'm getting dependency problems with the new mod_php on SuSE 7.1:

# rpm -Fhv /rhul_suse/important-7.1/mod_php.rpm
error: failed dependencies:
libcrypto.so.0.9.6 is needed by mod_php-3.0.17RC1-54
libssl.so.0.9.6 is needed by mod_php-3.0.17RC1-54

The old version gives:

# rpm -q mod_php
mod_php-3.0.17RC1-29
# rpm -q -R mod_php | egrep 'libcrypto|libssl'
libcrypto.so.0
libssl.so.0

The new version gives:

# rpm -q -p /rhul_suse/important-7.1/mod_php.rpm
mod_php-3.0.17RC1-54
# rpm -q -R -p /rhul_suse/important-7.1/mod_php.rpm | egrep 'libcrypto|libssl'
libcrypto.so.0.9.6
libssl.so.0.9.6

ldconfig says:

# ldconfig -p | grep crypt
libcrypto.so.0 (libc6) => /usr/lib/libcrypto.so.0
libcrypto.so (libc6) => /usr/lib/libcrypto.so
libcrypt.so.1 (libc6) => /lib/libcrypt.so.1
libcrypt.so (libc6) => /usr/lib/libcrypt.so
# ldconfig -p | grep ssl
libssl.so.0 (libc6) => /usr/lib/libssl.so.0
libssl.so (libc6) => /usr/lib/libssl.so



Should I force it or do I need to install some other updates?
Thanks,
Bob
==============================================================
Bob Vickers R.Vickers@xxxxxxxxxxxxx
Dept of Computer Science, Royal Holloway, University of London
WWW: http://www.cs.rhul.ac.uk/home/bobv
Phone: +44 1784 443691


< Previous Next >
Follow Ups