Mailinglist Archive: opensuse-security-announce (38 mails)

< Previous Next >
[security-announce] openSUSE-SU-2020:0170-1: moderate: Security update for ImageMagick
openSUSE Security Update: Security update for ImageMagick
______________________________________________________________________________

Announcement ID: openSUSE-SU-2020:0170-1
Rating: moderate
References: #1159861 #1160369 #1161194
Cross-References: CVE-2019-19948 CVE-2019-19949
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that solves two vulnerabilities and has one
errata is now available.

Description:

This update for ImageMagick fixes the following issues:

Security issue fixed:

- CVE-2019-19948: Fixed a heap-based buffer overflow in WriteSGIImage()
(bsc#1159861).
- CVE-2019-19949: Fixed a heap-based buffer over-read in WritePNGImage()
(bsc#1160369).

Non-security issue fixed:

- Fixed an issue where converting tiff to png would lead to unviewable
files (bsc#1161194).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2020-170=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

ImageMagick-7.0.7.34-lp151.7.15.1
ImageMagick-config-7-SUSE-7.0.7.34-lp151.7.15.1
ImageMagick-config-7-upstream-7.0.7.34-lp151.7.15.1
ImageMagick-debuginfo-7.0.7.34-lp151.7.15.1
ImageMagick-debugsource-7.0.7.34-lp151.7.15.1
ImageMagick-devel-7.0.7.34-lp151.7.15.1
ImageMagick-extra-7.0.7.34-lp151.7.15.1
ImageMagick-extra-debuginfo-7.0.7.34-lp151.7.15.1
libMagick++-7_Q16HDRI4-7.0.7.34-lp151.7.15.1
libMagick++-7_Q16HDRI4-debuginfo-7.0.7.34-lp151.7.15.1
libMagick++-devel-7.0.7.34-lp151.7.15.1
libMagickCore-7_Q16HDRI6-7.0.7.34-lp151.7.15.1
libMagickCore-7_Q16HDRI6-debuginfo-7.0.7.34-lp151.7.15.1
libMagickWand-7_Q16HDRI6-7.0.7.34-lp151.7.15.1
libMagickWand-7_Q16HDRI6-debuginfo-7.0.7.34-lp151.7.15.1
perl-PerlMagick-7.0.7.34-lp151.7.15.1
perl-PerlMagick-debuginfo-7.0.7.34-lp151.7.15.1

- openSUSE Leap 15.1 (x86_64):

ImageMagick-devel-32bit-7.0.7.34-lp151.7.15.1
libMagick++-7_Q16HDRI4-32bit-7.0.7.34-lp151.7.15.1
libMagick++-7_Q16HDRI4-32bit-debuginfo-7.0.7.34-lp151.7.15.1
libMagick++-devel-32bit-7.0.7.34-lp151.7.15.1
libMagickCore-7_Q16HDRI6-32bit-7.0.7.34-lp151.7.15.1
libMagickCore-7_Q16HDRI6-32bit-debuginfo-7.0.7.34-lp151.7.15.1
libMagickWand-7_Q16HDRI6-32bit-7.0.7.34-lp151.7.15.1
libMagickWand-7_Q16HDRI6-32bit-debuginfo-7.0.7.34-lp151.7.15.1

- openSUSE Leap 15.1 (noarch):

ImageMagick-doc-7.0.7.34-lp151.7.15.1


References:

https://www.suse.com/security/cve/CVE-2019-19948.html
https://www.suse.com/security/cve/CVE-2019-19949.html
https://bugzilla.suse.com/1159861
https://bugzilla.suse.com/1160369
https://bugzilla.suse.com/1161194

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages