Mailinglist Archive: opensuse-security-announce (79 mails)

< Previous Next >
[security-announce] openSUSE-SU-2019:2575-1: important: Security update for cups
openSUSE Security Update: Security update for cups
______________________________________________________________________________

Announcement ID: openSUSE-SU-2019:2575-1
Rating: important
References: #1146358 #1146359
Cross-References: CVE-2019-8675 CVE-2019-8696
Affected Products:
openSUSE Leap 15.1
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for cups fixes the following issues:

- CVE-2019-8675: Fixed a stack buffer overflow in libcups's asn1_get_type
function(bsc#1146358).
- CVE-2019-8696: Fixed a stack buffer overflow in libcups's
asn1_get_packed function (bsc#1146359).

This update was imported from the SUSE:SLE-15:Update update project.


Patch Instructions:

To install this openSUSE Security Update use the SUSE recommended
installation methods
like YaST online_update or "zypper patch".

Alternatively you can run the command listed for your product:

- openSUSE Leap 15.1:

zypper in -t patch openSUSE-2019-2575=1



Package List:

- openSUSE Leap 15.1 (i586 x86_64):

cups-2.2.7-lp151.6.3.1
cups-client-2.2.7-lp151.6.3.1
cups-client-debuginfo-2.2.7-lp151.6.3.1
cups-config-2.2.7-lp151.6.3.1
cups-ddk-2.2.7-lp151.6.3.1
cups-ddk-debuginfo-2.2.7-lp151.6.3.1
cups-debuginfo-2.2.7-lp151.6.3.1
cups-debugsource-2.2.7-lp151.6.3.1
cups-devel-2.2.7-lp151.6.3.1
libcups2-2.2.7-lp151.6.3.1
libcups2-debuginfo-2.2.7-lp151.6.3.1
libcupscgi1-2.2.7-lp151.6.3.1
libcupscgi1-debuginfo-2.2.7-lp151.6.3.1
libcupsimage2-2.2.7-lp151.6.3.1
libcupsimage2-debuginfo-2.2.7-lp151.6.3.1
libcupsmime1-2.2.7-lp151.6.3.1
libcupsmime1-debuginfo-2.2.7-lp151.6.3.1
libcupsppdc1-2.2.7-lp151.6.3.1
libcupsppdc1-debuginfo-2.2.7-lp151.6.3.1

- openSUSE Leap 15.1 (x86_64):

cups-devel-32bit-2.2.7-lp151.6.3.1
libcups2-32bit-2.2.7-lp151.6.3.1
libcups2-32bit-debuginfo-2.2.7-lp151.6.3.1
libcupscgi1-32bit-2.2.7-lp151.6.3.1
libcupscgi1-32bit-debuginfo-2.2.7-lp151.6.3.1
libcupsimage2-32bit-2.2.7-lp151.6.3.1
libcupsimage2-32bit-debuginfo-2.2.7-lp151.6.3.1
libcupsmime1-32bit-2.2.7-lp151.6.3.1
libcupsmime1-32bit-debuginfo-2.2.7-lp151.6.3.1
libcupsppdc1-32bit-2.2.7-lp151.6.3.1
libcupsppdc1-32bit-debuginfo-2.2.7-lp151.6.3.1


References:

https://www.suse.com/security/cve/CVE-2019-8675.html
https://www.suse.com/security/cve/CVE-2019-8696.html
https://bugzilla.suse.com/1146358
https://bugzilla.suse.com/1146359

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages