Mailinglist Archive: opensuse-security-announce (81 mails)

< Previous Next >
[security-announce] SUSE-SU-2017:1446-1: important: Security update for sudo
SUSE Security Update: Security update for sudo
______________________________________________________________________________

Announcement ID: SUSE-SU-2017:1446-1
Rating: important
References: #1015351 #1024145 #1039361 #981124
Cross-References: CVE-2017-1000367
Affected Products:
SUSE Linux Enterprise Software Development Kit 12-SP1
SUSE Linux Enterprise Server for SAP 12
SUSE Linux Enterprise Server 12-SP1
SUSE Linux Enterprise Server 12-LTSS
SUSE Linux Enterprise Desktop 12-SP1
______________________________________________________________________________

An update that solves one vulnerability and has three fixes
is now available.

Description:


This update for sudo fixes the following issues:

CVE-2017-1000367:
- Due to incorrect assumptions in /proc/[pid]/stat parsing, a local
attacker can pretend that his tty is any file on the filesystem, thus
gaining arbitrary file write access on SELinux-enabled systems.
[bsc#1039361]
- Fix FQDN for hostname. [bsc#1024145]
- Filter netgroups, they aren't handled by SSSD. [bsc#1015351]
- Fix problems related to "krb5_ccname" option [bsc#981124]


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 12-SP1:

zypper in -t patch SUSE-SLE-SDK-12-SP1-2017-888=1

- SUSE Linux Enterprise Server for SAP 12:

zypper in -t patch SUSE-SLE-SAP-12-2017-888=1

- SUSE Linux Enterprise Server 12-SP1:

zypper in -t patch SUSE-SLE-SERVER-12-SP1-2017-888=1

- SUSE Linux Enterprise Server 12-LTSS:

zypper in -t patch SUSE-SLE-SERVER-12-2017-888=1

- SUSE Linux Enterprise Desktop 12-SP1:

zypper in -t patch SUSE-SLE-DESKTOP-12-SP1-2017-888=1

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 12-SP1 (ppc64le s390x
x86_64):

sudo-debuginfo-1.8.10p3-2.11.1
sudo-debugsource-1.8.10p3-2.11.1
sudo-devel-1.8.10p3-2.11.1

- SUSE Linux Enterprise Server for SAP 12 (x86_64):

sudo-1.8.10p3-2.11.1
sudo-debuginfo-1.8.10p3-2.11.1
sudo-debugsource-1.8.10p3-2.11.1

- SUSE Linux Enterprise Server 12-SP1 (ppc64le s390x x86_64):

sudo-1.8.10p3-2.11.1
sudo-debuginfo-1.8.10p3-2.11.1
sudo-debugsource-1.8.10p3-2.11.1

- SUSE Linux Enterprise Server 12-LTSS (ppc64le s390x x86_64):

sudo-1.8.10p3-2.11.1
sudo-debuginfo-1.8.10p3-2.11.1
sudo-debugsource-1.8.10p3-2.11.1

- SUSE Linux Enterprise Desktop 12-SP1 (x86_64):

sudo-1.8.10p3-2.11.1
sudo-debuginfo-1.8.10p3-2.11.1
sudo-debugsource-1.8.10p3-2.11.1


References:

https://www.suse.com/security/cve/CVE-2017-1000367.html
https://bugzilla.suse.com/1015351
https://bugzilla.suse.com/1024145
https://bugzilla.suse.com/1039361
https://bugzilla.suse.com/981124

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages