Mailinglist Archive: opensuse-security-announce (49 mails)

< Previous Next >
[security-announce] openSUSE-SU-2017:0510-1: important: Security update for opus
openSUSE Security Update: Security update for opus
______________________________________________________________________________

Announcement ID: openSUSE-SU-2017:0510-1
Rating: important
References: #1020102
Cross-References: CVE-2017-0381
Affected Products:
openSUSE Leap 42.2
openSUSE Leap 42.1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:


This update for opus fixes the following issues:

- CVE-2017-0381: Fixed a remote code execution vulnerability in
silk/NLSF_stabilize.c when playing certain media files (bsc#1020102)

This update was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.2:

zypper in -t patch openSUSE-2017-277=1

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2017-277=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.2 (i586 x86_64):

libopus-devel-1.1-6.1
libopus-devel-static-1.1-6.1
libopus0-1.1-6.1
libopus0-debuginfo-1.1-6.1
opus-debugsource-1.1-6.1

- openSUSE Leap 42.2 (x86_64):

libopus0-32bit-1.1-6.1
libopus0-debuginfo-32bit-1.1-6.1

- openSUSE Leap 42.1 (i586 x86_64):

libopus-devel-1.1-5.1
libopus-devel-static-1.1-5.1
libopus0-1.1-5.1
libopus0-debuginfo-1.1-5.1
opus-debugsource-1.1-5.1

- openSUSE Leap 42.1 (x86_64):

libopus0-32bit-1.1-5.1
libopus0-debuginfo-32bit-1.1-5.1


References:

https://www.suse.com/security/cve/CVE-2017-0381.html
https://bugzilla.suse.com/1020102

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages