Mailinglist Archive: opensuse-security-announce (62 mails)

< Previous Next >
[security-announce] openSUSE-SU-2016:1523-1: important: Security update for expat
openSUSE Security Update: Security update for expat
______________________________________________________________________________

Announcement ID: openSUSE-SU-2016:1523-1
Rating: important
References: #979441 #980391
Cross-References: CVE-2015-1283 CVE-2016-0718
Affected Products:
openSUSE Leap 42.1
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

This update for expat fixes the following issues:

Security issue fixed:
- CVE-2016-0718: Fix Expat XML parser that mishandles certain kinds of
malformed input documents. (bsc#979441)
- CVE-2015-1283: Fix multiple integer overflows. (bnc#980391) This update
was imported from the SUSE:SLE-12:Update update project.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE Leap 42.1:

zypper in -t patch openSUSE-2016-695=1

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE Leap 42.1 (i586 x86_64):

expat-2.1.0-17.1
expat-debuginfo-2.1.0-17.1
expat-debugsource-2.1.0-17.1
libexpat-devel-2.1.0-17.1
libexpat1-2.1.0-17.1
libexpat1-debuginfo-2.1.0-17.1

- openSUSE Leap 42.1 (x86_64):

expat-debuginfo-32bit-2.1.0-17.1
libexpat-devel-32bit-2.1.0-17.1
libexpat1-32bit-2.1.0-17.1
libexpat1-debuginfo-32bit-2.1.0-17.1


References:

https://www.suse.com/security/cve/CVE-2015-1283.html
https://www.suse.com/security/cve/CVE-2016-0718.html
https://bugzilla.suse.com/979441
https://bugzilla.suse.com/980391

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages