Mailinglist Archive: opensuse-security-announce (28 mails)

< Previous Next >
[security-announce] SUSE-SU-2015:0929-1: important: Security update for KVM
SUSE Security Update: Security update for KVM
______________________________________________________________________________

Announcement ID: SUSE-SU-2015:0929-1
Rating: important
References: #877642 #877645 #929339
Cross-References: CVE-2014-0222 CVE-2014-0223 CVE-2015-3456

Affected Products:
SUSE Linux Enterprise Server 11 SP1 LTSS
______________________________________________________________________________

An update that fixes three vulnerabilities is now
available. It includes one version update.

Description:


KVM was updated to fix the following security issues:

* CVE-2015-3456: Buffer overflow in the floppy drive emulation, which
could be used to carry out denial of service attacks or potential
code execution against the host. This vulnerability is also known as
VENOM.
* CVE-2014-0222: Integer overflow in the qcow_open function in
block/qcow.c in QEMU allowed remote attackers to cause a denial of
service (crash) via a large L2 table in a QCOW version 1 image.
* CVE-2014-0223: Integer overflow in the qcow_open function in
block/qcow.c in QEMU allowed local users to cause a denial of
service (crash) and possibly execute arbitrary code via a large
image size, which triggers a buffer overflow or out-of-bounds read.

Security Issues:

* CVE-2015-3456
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2015-3456>
* CVE-2014-0222
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-0222>
* CVE-2014-0223
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-0223>


Special Instructions and Notes:

Please reboot the system after installing this update.

Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Server 11 SP1 LTSS:

zypper in -t patch slessp1-kvm=10683

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Server 11 SP1 LTSS (i586 x86_64) [New Version:
0.12.5]:

kvm-0.12.5-1.26.1


References:

https://www.suse.com/security/cve/CVE-2014-0222.html
https://www.suse.com/security/cve/CVE-2014-0223.html
https://www.suse.com/security/cve/CVE-2015-3456.html
https://bugzilla.suse.com/877642
https://bugzilla.suse.com/877645
https://bugzilla.suse.com/929339

https://download.suse.com/patch/finder/?keywords=a793805e5c8b31d54aefde03808c673c

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages