Mailinglist Archive: opensuse-security-announce (50 mails)

< Previous Next >
[security-announce] SUSE-SU-2014:1125-1: important: Security update for glibc
SUSE Security Update: Security update for glibc
______________________________________________________________________________

Announcement ID: SUSE-SU-2014:1125-1
Rating: important
References: #888347 #892065 #892073
Cross-References: CVE-2014-5119
Affected Products:
SUSE Linux Enterprise Software Development Kit 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Desktop 11 SP3
______________________________________________________________________________

An update that solves one vulnerability and has two fixes
is now available.

Description:


This glibc update fixes a critical privilege escalation problem and two
non-security issues:

* bnc#892073: An off-by-one error leading to a heap-based buffer
overflow was found in __gconv_translit_find(). An exploit that
targets the problem is publicly available. (CVE-2014-5119)
* bnc#892065: setenv-alloca.patch: Avoid unbound alloca in setenv.
* bnc#888347: printf-multibyte-format.patch: Don't parse %s format
argument as multi-byte string.

Security Issues:

* CVE-2014-5119
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-5119>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11 SP3:

zypper in -t patch sdksp3-glibc-9669

- SUSE Linux Enterprise Server 11 SP3 for VMware:

zypper in -t patch slessp3-glibc-9669

- SUSE Linux Enterprise Server 11 SP3:

zypper in -t patch slessp3-glibc-9669

- SUSE Linux Enterprise Desktop 11 SP3:

zypper in -t patch sledsp3-glibc-9669

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11 SP3 (i586 x86_64):

glibc-html-2.11.3-17.72.14
glibc-info-2.11.3-17.72.14

- SUSE Linux Enterprise Server 11 SP3 for VMware (i586 x86_64):

glibc-2.11.3-17.72.14
glibc-devel-2.11.3-17.72.14
glibc-html-2.11.3-17.72.14
glibc-i18ndata-2.11.3-17.72.14
glibc-info-2.11.3-17.72.14
glibc-locale-2.11.3-17.72.14
glibc-profile-2.11.3-17.72.14
nscd-2.11.3-17.72.14

- SUSE Linux Enterprise Server 11 SP3 for VMware (x86_64):

glibc-32bit-2.11.3-17.72.14
glibc-devel-32bit-2.11.3-17.72.14
glibc-locale-32bit-2.11.3-17.72.14
glibc-profile-32bit-2.11.3-17.72.14

- SUSE Linux Enterprise Server 11 SP3 (i586 i686 ia64 ppc64 s390x x86_64):

glibc-2.11.3-17.72.14
glibc-devel-2.11.3-17.72.14

- SUSE Linux Enterprise Server 11 SP3 (i586 ia64 ppc64 s390x x86_64):

glibc-html-2.11.3-17.72.14
glibc-i18ndata-2.11.3-17.72.14
glibc-info-2.11.3-17.72.14
glibc-locale-2.11.3-17.72.14
glibc-profile-2.11.3-17.72.14
nscd-2.11.3-17.72.14

- SUSE Linux Enterprise Server 11 SP3 (ppc64 s390x x86_64):

glibc-32bit-2.11.3-17.72.14
glibc-devel-32bit-2.11.3-17.72.14
glibc-locale-32bit-2.11.3-17.72.14
glibc-profile-32bit-2.11.3-17.72.14

- SUSE Linux Enterprise Server 11 SP3 (ia64):

glibc-locale-x86-2.11.3-17.72.14
glibc-profile-x86-2.11.3-17.72.14
glibc-x86-2.11.3-17.72.14

- SUSE Linux Enterprise Desktop 11 SP3 (i586 i686 x86_64):

glibc-2.11.3-17.72.14
glibc-devel-2.11.3-17.72.14

- SUSE Linux Enterprise Desktop 11 SP3 (i586 x86_64):

glibc-i18ndata-2.11.3-17.72.14
glibc-locale-2.11.3-17.72.14
nscd-2.11.3-17.72.14

- SUSE Linux Enterprise Desktop 11 SP3 (x86_64):

glibc-32bit-2.11.3-17.72.14
glibc-devel-32bit-2.11.3-17.72.14
glibc-locale-32bit-2.11.3-17.72.14


References:

http://support.novell.com/security/cve/CVE-2014-5119.html
https://bugzilla.novell.com/888347
https://bugzilla.novell.com/892065
https://bugzilla.novell.com/892073

http://download.suse.com/patch/finder/?keywords=b84219db4b55e263e5f4c158906891f0

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages