Mailinglist Archive: opensuse-security-announce (25 mails)

< Previous Next >
[security-announce] SUSE-SU-2014:0868-1: important: Security update for PHP5
SUSE Security Update: Security update for PHP5
______________________________________________________________________________

Announcement ID: SUSE-SU-2014:0868-1
Rating: important
References: #868624 #882992
Cross-References: CVE-2014-2497 CVE-2014-4049
Affected Products:
SUSE Linux Enterprise Server 11 SP2 LTSS
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:


PHP5 has been updated to fix two security vulnerabilities:

* Heap-based buffer overflow in DNS TXT record parsing (CVE-2014-4049)
* NULL pointer dereference in GD XPM decoder (CVE-2014-2497)

Security Issue references:

* CVE-2014-4049
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-4049>
* CVE-2014-2497
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-2497>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Server 11 SP2 LTSS:

zypper in -t patch slessp2-apache2-mod_php5-9409

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Server 11 SP2 LTSS (i586 s390x x86_64):

apache2-mod_php5-5.2.14-0.7.30.54.1
php5-5.2.14-0.7.30.54.1
php5-bcmath-5.2.14-0.7.30.54.1
php5-bz2-5.2.14-0.7.30.54.1
php5-calendar-5.2.14-0.7.30.54.1
php5-ctype-5.2.14-0.7.30.54.1
php5-curl-5.2.14-0.7.30.54.1
php5-dba-5.2.14-0.7.30.54.1
php5-dbase-5.2.14-0.7.30.54.1
php5-dom-5.2.14-0.7.30.54.1
php5-exif-5.2.14-0.7.30.54.1
php5-fastcgi-5.2.14-0.7.30.54.1
php5-ftp-5.2.14-0.7.30.54.1
php5-gd-5.2.14-0.7.30.54.1
php5-gettext-5.2.14-0.7.30.54.1
php5-gmp-5.2.14-0.7.30.54.1
php5-hash-5.2.14-0.7.30.54.1
php5-iconv-5.2.14-0.7.30.54.1
php5-json-5.2.14-0.7.30.54.1
php5-ldap-5.2.14-0.7.30.54.1
php5-mbstring-5.2.14-0.7.30.54.1
php5-mcrypt-5.2.14-0.7.30.54.1
php5-mysql-5.2.14-0.7.30.54.1
php5-odbc-5.2.14-0.7.30.54.1
php5-openssl-5.2.14-0.7.30.54.1
php5-pcntl-5.2.14-0.7.30.54.1
php5-pdo-5.2.14-0.7.30.54.1
php5-pear-5.2.14-0.7.30.54.1
php5-pgsql-5.2.14-0.7.30.54.1
php5-pspell-5.2.14-0.7.30.54.1
php5-shmop-5.2.14-0.7.30.54.1
php5-snmp-5.2.14-0.7.30.54.1
php5-soap-5.2.14-0.7.30.54.1
php5-suhosin-5.2.14-0.7.30.54.1
php5-sysvmsg-5.2.14-0.7.30.54.1
php5-sysvsem-5.2.14-0.7.30.54.1
php5-sysvshm-5.2.14-0.7.30.54.1
php5-tokenizer-5.2.14-0.7.30.54.1
php5-wddx-5.2.14-0.7.30.54.1
php5-xmlreader-5.2.14-0.7.30.54.1
php5-xmlrpc-5.2.14-0.7.30.54.1
php5-xmlwriter-5.2.14-0.7.30.54.1
php5-xsl-5.2.14-0.7.30.54.1
php5-zip-5.2.14-0.7.30.54.1
php5-zlib-5.2.14-0.7.30.54.1


References:

http://support.novell.com/security/cve/CVE-2014-2497.html
http://support.novell.com/security/cve/CVE-2014-4049.html
https://bugzilla.novell.com/868624
https://bugzilla.novell.com/882992

http://download.suse.com/patch/finder/?keywords=5a6e6d1523035a22186fef4bad38da0d

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages