Mailinglist Archive: opensuse-security-announce (32 mails)

< Previous Next >
[security-announce] openSUSE-SU-2014:0767-1: important: gnutls: Fixed possible memory corruption
openSUSE Security Update: gnutls: Fixed possible memory corruption
______________________________________________________________________________

Announcement ID: openSUSE-SU-2014:0767-1
Rating: important
References: #880730
Cross-References: CVE-2014-3466
Affected Products:
openSUSE 11.4
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:

gnutls was patched to fix security vulnerability that could be used to
disrupt service or potentially allow remote code execution.
- Memory corruption during connect (CVE-2014-3466)
- NULL pointer dereference in gnutls_x509_dn_oid_name (CVE-2014-3465)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch 2014-59

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64):

gnutls-2.8.6-5.29.1
gnutls-debuginfo-2.8.6-5.29.1
gnutls-debugsource-2.8.6-5.29.1
libgnutls-devel-2.8.6-5.29.1
libgnutls-extra-devel-2.8.6-5.29.1
libgnutls-extra26-2.8.6-5.29.1
libgnutls-extra26-debuginfo-2.8.6-5.29.1
libgnutls26-2.8.6-5.29.1
libgnutls26-debuginfo-2.8.6-5.29.1

- openSUSE 11.4 (x86_64):

libgnutls26-32bit-2.8.6-5.29.1
libgnutls26-debuginfo-32bit-2.8.6-5.29.1

- openSUSE 11.4 (ia64):

libgnutls26-debuginfo-x86-2.8.6-5.29.1
libgnutls26-x86-2.8.6-5.29.1


References:

http://support.novell.com/security/cve/CVE-2014-3466.html
https://bugzilla.novell.com/880730

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages