Mailinglist Archive: opensuse-security-announce (32 mails)

< Previous Next >
[security-announce] openSUSE-SU-2014:0763-1: important: gnutls: Fixed possible memory corruption and NULL pointer dereference
openSUSE Security Update: gnutls: Fixed possible memory corruption and NULL
pointer dereference
______________________________________________________________________________

Announcement ID: openSUSE-SU-2014:0763-1
Rating: important
References: #880730 #880733
Cross-References: CVE-2014-3465 CVE-2014-3466
Affected Products:
openSUSE 13.1
openSUSE 12.3
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:

gnutls was patched to fix two security vulnerabilities that could be used
to disrupt service or potentially allow remote code execution.

- Memory corruption during connect (CVE-2014-3466)
- NULL pointer dereference in gnutls_x509_dn_oid_name (CVE-2014-3465)


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 13.1:

zypper in -t patch openSUSE-2014-411

- openSUSE 12.3:

zypper in -t patch openSUSE-2014-411

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 13.1 (i586 x86_64):

gnutls-3.2.4-2.24.1
gnutls-debuginfo-3.2.4-2.24.1
gnutls-debugsource-3.2.4-2.24.1
libgnutls-devel-3.2.4-2.24.1
libgnutls-openssl-devel-3.2.4-2.24.1
libgnutls-openssl27-3.2.4-2.24.1
libgnutls-openssl27-debuginfo-3.2.4-2.24.1
libgnutls28-3.2.4-2.24.1
libgnutls28-debuginfo-3.2.4-2.24.1
libgnutlsxx-devel-3.2.4-2.24.1
libgnutlsxx28-3.2.4-2.24.1
libgnutlsxx28-debuginfo-3.2.4-2.24.1

- openSUSE 13.1 (x86_64):

libgnutls-devel-32bit-3.2.4-2.24.1
libgnutls28-32bit-3.2.4-2.24.1
libgnutls28-debuginfo-32bit-3.2.4-2.24.1

- openSUSE 12.3 (i586 x86_64):

gnutls-3.0.28-1.14.1
gnutls-debuginfo-3.0.28-1.14.1
gnutls-debugsource-3.0.28-1.14.1
libgnutls-devel-3.0.28-1.14.1
libgnutls-openssl-devel-3.0.28-1.14.1
libgnutls-openssl27-3.0.28-1.14.1
libgnutls-openssl27-debuginfo-3.0.28-1.14.1
libgnutls28-3.0.28-1.14.1
libgnutls28-debuginfo-3.0.28-1.14.1
libgnutlsxx-devel-3.0.28-1.14.1
libgnutlsxx28-3.0.28-1.14.1
libgnutlsxx28-debuginfo-3.0.28-1.14.1

- openSUSE 12.3 (x86_64):

libgnutls-devel-32bit-3.0.28-1.14.1
libgnutls28-32bit-3.0.28-1.14.1
libgnutls28-debuginfo-32bit-3.0.28-1.14.1


References:

http://support.novell.com/security/cve/CVE-2014-3465.html
http://support.novell.com/security/cve/CVE-2014-3466.html
https://bugzilla.novell.com/880730
https://bugzilla.novell.com/880733

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages