Mailinglist Archive: opensuse-security-announce (18 mails)

< Previous Next >
[security-announce] SUSE-SU-2014:0474-1: important: Security update for lighttpd
SUSE Security Update: Security update for lighttpd
______________________________________________________________________________

Announcement ID: SUSE-SU-2014:0474-1
Rating: important
References: #867350
Cross-References: CVE-2014-2323 CVE-2014-2324
Affected Products:
SUSE Linux Enterprise Software Development Kit 11 SP3
SUSE Linux Enterprise High Availability Extension 11 SP3
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:


The HTTP server lighttpd was updated to fix the following
security issues:

* CVE-2014-2323: SQL injection vulnerability in
mod_mysql_vhost.c in lighttpd allowed remote attackers to
execute arbitrary SQL commands via the host name.
* CVE-2014-2323: Multiple directory traversal
vulnerabilities in mod_evhost and mod_simple_vhost in
lighttpd allowed remote attackers to read arbitrary files
via .. (dot dot) in the host name.

More information can be found on the lighttpd advisory
page:
http://download.lighttpd.net/lighttpd/security/lighttpd_sa_2
014_01.txt
<http://download.lighttpd.net/lighttpd/security/lighttpd_sa_
2014_01.txt>

Security Issues references:

* CVE-2014-2323
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-2323
>
* CVE-2014-2324
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2014-2324
>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11 SP3:

zypper in -t patch sdksp3-lighttpd-9031

- SUSE Linux Enterprise High Availability Extension 11 SP3:

zypper in -t patch slehasp3-lighttpd-9031

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11 SP3 (i586 ia64 ppc64
s390x x86_64):

lighttpd-1.4.20-2.54.1
lighttpd-mod_cml-1.4.20-2.54.1
lighttpd-mod_magnet-1.4.20-2.54.1
lighttpd-mod_mysql_vhost-1.4.20-2.54.1
lighttpd-mod_rrdtool-1.4.20-2.54.1
lighttpd-mod_trigger_b4_dl-1.4.20-2.54.1
lighttpd-mod_webdav-1.4.20-2.54.1

- SUSE Linux Enterprise High Availability Extension 11 SP3 (i586 ia64 ppc64
s390x x86_64):

lighttpd-1.4.20-2.54.1


References:

http://support.novell.com/security/cve/CVE-2014-2323.html
http://support.novell.com/security/cve/CVE-2014-2324.html
https://bugzilla.novell.com/867350

http://download.suse.com/patch/finder/?keywords=052dffefc1e084c898a83671a4359f4c

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages