Mailinglist Archive: opensuse-security-announce (27 mails)

< Previous Next >
[security-announce] openSUSE-SU-2014:0328-1: critical: gnutls: fixed SSL certificate validation
openSUSE Security Update: gnutls: fixed SSL certificate validation
______________________________________________________________________________

Announcement ID: openSUSE-SU-2014:0328-1
Rating: critical
References: #865804
Cross-References: CVE-2014-0092
Affected Products:
openSUSE 12.3
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:


The gnutls library was updated to fix SSL certificate
validation. Remote man-in-the-middle attackers were able to
make the verification believe that a SSL certificate is
valid even though it was not.


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 12.3:

zypper in -t patch openSUSE-2014-183

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 12.3 (i586 x86_64):

gnutls-3.0.28-1.4.1
gnutls-debuginfo-3.0.28-1.4.1
gnutls-debugsource-3.0.28-1.4.1
libgnutls-devel-3.0.28-1.4.1
libgnutls-openssl-devel-3.0.28-1.4.1
libgnutls-openssl27-3.0.28-1.4.1
libgnutls-openssl27-debuginfo-3.0.28-1.4.1
libgnutls28-3.0.28-1.4.1
libgnutls28-debuginfo-3.0.28-1.4.1
libgnutlsxx-devel-3.0.28-1.4.1
libgnutlsxx28-3.0.28-1.4.1
libgnutlsxx28-debuginfo-3.0.28-1.4.1

- openSUSE 12.3 (x86_64):

libgnutls-devel-32bit-3.0.28-1.4.1
libgnutls28-32bit-3.0.28-1.4.1
libgnutls28-debuginfo-32bit-3.0.28-1.4.1


References:

http://support.novell.com/security/cve/CVE-2014-0092.html
https://bugzilla.novell.com/865804

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages