Mailinglist Archive: opensuse-security-announce (10 mails)

< Previous Next >
[security-announce] SUSE-SU-2014:0155-1: important: Security update for puppet
SUSE Security Update: Security update for puppet
______________________________________________________________________________

Announcement ID: SUSE-SU-2014:0155-1
Rating: important
References: #835122 #853982
Cross-References: CVE-2013-4761
Affected Products:
SUSE Linux Enterprise Server 11 SP3 for VMware
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP2 for VMware
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Desktop 11 SP2
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available. It includes one version update.

Description:


This update for puppet fixes a remote code execution
vulnerability in the "resource_type" service.
(CVE-2013-4761)

Additionally, the update prevents puppet from executing
initialization scripts that could trigger a system reboot
when handling "puppet resource service" calls.

Security Issue reference:

* CVE-2013-4761
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2013-4761
>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Server 11 SP3 for VMware:

zypper in -t patch slessp3-puppet-8812

- SUSE Linux Enterprise Server 11 SP3:

zypper in -t patch slessp3-puppet-8812

- SUSE Linux Enterprise Server 11 SP2 for VMware:

zypper in -t patch slessp2-puppet-8811

- SUSE Linux Enterprise Server 11 SP2:

zypper in -t patch slessp2-puppet-8811

- SUSE Linux Enterprise Desktop 11 SP3:

zypper in -t patch sledsp3-puppet-8812

- SUSE Linux Enterprise Desktop 11 SP2:

zypper in -t patch sledsp2-puppet-8811

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Server 11 SP3 for VMware (i586 x86_64):

puppet-2.6.18-0.12.1
puppet-server-2.6.18-0.12.1

- SUSE Linux Enterprise Server 11 SP3 (i586 ia64 ppc64 s390x x86_64):

puppet-2.6.18-0.12.1
puppet-server-2.6.18-0.12.1

- SUSE Linux Enterprise Server 11 SP2 for VMware (i586 x86_64) [New Version:
2.6.18]:

puppet-2.6.18-0.12.1
puppet-server-2.6.18-0.12.1

- SUSE Linux Enterprise Server 11 SP2 (i586 ia64 ppc64 s390x x86_64) [New
Version: 2.6.18]:

puppet-2.6.18-0.12.1
puppet-server-2.6.18-0.12.1

- SUSE Linux Enterprise Desktop 11 SP3 (i586 x86_64):

puppet-2.6.18-0.12.1

- SUSE Linux Enterprise Desktop 11 SP2 (i586 x86_64) [New Version: 2.6.18]:

puppet-2.6.18-0.12.1


References:

http://support.novell.com/security/cve/CVE-2013-4761.html
https://bugzilla.novell.com/835122
https://bugzilla.novell.com/853982

http://download.novell.com/patch/finder/?keywords=7107f4238800d8be5194203b85b2b3f8

http://download.novell.com/patch/finder/?keywords=d16a0df5a7c526b2fb71f3b5f9a79da8

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
List Navigation
This Thread
  • No further messages