Mailinglist Archive: opensuse-security-announce (24 mails)

< Previous Next >
[security-announce] openSUSE-SU-2013:0635-1: important: postgresql: security and bugfix update to 9.0.13
openSUSE Security Update: postgresql: security and bugfix update to 9.0.13
______________________________________________________________________________

Announcement ID: openSUSE-SU-2013:0635-1
Rating: important
References: #812525
Cross-References: CVE-2013-1899 CVE-2013-1900 CVE-2013-1901

Affected Products:
openSUSE 11.4
______________________________________________________________________________

An update that fixes three vulnerabilities is now available.

Description:

Postgresql was updated to version 9.0.13 (bnc#812525):
* CVE-2013-1899: Fix insecure parsing of server
command-line switches. A connection request containing
a database name that begins with "-" could be crafted
to damage or destroy files within the server's data
directory, even if the request is eventually rejected.
* CVE-2013-1900: Reset OpenSSL randomness state in each
postmaster child process. This avoids a scenario wherein
random numbers generated by "contrib/pgcrypto" functions
might be relatively easy for another database user to
guess. The risk is only significant when the postmaster is
configured with ssl = on but most connections don't use SSL
encryption.
* CVE-2013-1901: Make REPLICATION privilege checks test
current user not authenticated user. An unprivileged
database user could exploit this mistake to call
pg_start_backup() or pg_stop_backup(), thus possibly
interfering with creation of routine backups.
* See the release notes for the rest of the changes:
http://www.postgresql.org/docs/9.0/static/release-9-0-13.htm
l /usr/share/doc/packages/postgresql91/HISTORY


Patch Instructions:

To install this openSUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- openSUSE 11.4:

zypper in -t patch 2013-59

To bring your system up-to-date, use "zypper patch".


Package List:

- openSUSE 11.4 (i586 x86_64):

libecpg6-9.0.13-31.1
libecpg6-debuginfo-9.0.13-31.1
libpq5-9.0.13-31.1
libpq5-debuginfo-9.0.13-31.1
postgresql-9.0.13-31.1
postgresql-contrib-9.0.13-31.1
postgresql-contrib-debuginfo-9.0.13-31.1
postgresql-debuginfo-9.0.13-31.1
postgresql-debugsource-9.0.13-31.1
postgresql-devel-9.0.13-31.1
postgresql-devel-debuginfo-9.0.13-31.1
postgresql-libs-debugsource-9.0.13-31.1
postgresql-plperl-9.0.13-31.1
postgresql-plperl-debuginfo-9.0.13-31.1
postgresql-plpython-9.0.13-31.1
postgresql-plpython-debuginfo-9.0.13-31.1
postgresql-pltcl-9.0.13-31.1
postgresql-pltcl-debuginfo-9.0.13-31.1
postgresql-server-9.0.13-31.1
postgresql-server-debuginfo-9.0.13-31.1

- openSUSE 11.4 (x86_64):

libpq5-32bit-9.0.13-31.1
libpq5-debuginfo-32bit-9.0.13-31.1

- openSUSE 11.4 (noarch):

postgresql-docs-9.0.13-31.1

- openSUSE 11.4 (ia64):

libpq5-debuginfo-x86-9.0.13-31.1
libpq5-x86-9.0.13-31.1


References:

http://support.novell.com/security/cve/CVE-2013-1899.html
http://support.novell.com/security/cve/CVE-2013-1900.html
http://support.novell.com/security/cve/CVE-2013-1901.html
https://bugzilla.novell.com/812525

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages