Mailinglist Archive: opensuse-security-announce (37 mails)

< Previous Next >
[security-announce] SUSE-SU-2012:1231-1: important: Security update for IBM Java
SUSE Security Update: Security update for IBM Java
______________________________________________________________________________

Announcement ID: SUSE-SU-2012:1231-1
Rating: important
References: #780897
Cross-References: CVE-2012-0547 CVE-2012-0551 CVE-2012-1682
CVE-2012-1713 CVE-2012-1716 CVE-2012-1717
CVE-2012-1718 CVE-2012-1719 CVE-2012-1721
CVE-2012-1722 CVE-2012-1725 CVE-2012-1726
CVE-2012-3136 CVE-2012-4681
Affected Products:
SUSE Linux Enterprise Software Development Kit 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Java 11 SP2
______________________________________________________________________________

An update that fixes 14 vulnerabilities is now available.

Description:


IBM Java 1.7.0 was updated to SR2 which fixes critical
security issues.

Security Issue references:

* CVE-2012-4681
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-4681
>
* CVE-2012-1682
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1682
>
* CVE-2012-3136
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-3136
>
* CVE-2012-0547
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-0547
>
* CVE-2012-0551
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-0551
>
* CVE-2012-1717
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1717
>
* CVE-2012-1716
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1716
>
* CVE-2012-1713
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1713
>
* CVE-2012-1719
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1719
>
* CVE-2012-1718
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1718
>
* CVE-2012-1722
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1722
>
* CVE-2012-1721
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1721
>
* CVE-2012-1725
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1725
>
* CVE-2012-1726
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1726
>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11 SP2:

zypper in -t patch sdksp2-java-1_7_0-ibm-6839

- SUSE Linux Enterprise Server 11 SP2 for VMware:

zypper in -t patch slessp2-java-1_7_0-ibm-6839

- SUSE Linux Enterprise Server 11 SP2:

zypper in -t patch slessp2-java-1_7_0-ibm-6839

- SUSE Linux Enterprise Java 11 SP2:

zypper in -t patch slejsp2-java-1_7_0-ibm-6839

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11 SP2 (i586 ppc64 s390x
x86_64):

java-1_7_0-ibm-devel-1.7.0_sr2.0-0.5.1

- SUSE Linux Enterprise Server 11 SP2 for VMware (i586 x86_64):

java-1_7_0-ibm-1.7.0_sr2.0-0.5.1
java-1_7_0-ibm-jdbc-1.7.0_sr2.0-0.5.1
java-1_7_0-ibm-plugin-1.7.0_sr2.0-0.5.1

- SUSE Linux Enterprise Server 11 SP2 for VMware (i586):

java-1_7_0-ibm-alsa-1.7.0_sr2.0-0.5.1

- SUSE Linux Enterprise Server 11 SP2 (i586 ppc64 s390x x86_64):

java-1_7_0-ibm-1.7.0_sr2.0-0.5.1
java-1_7_0-ibm-jdbc-1.7.0_sr2.0-0.5.1

- SUSE Linux Enterprise Server 11 SP2 (i586 x86_64):

java-1_7_0-ibm-plugin-1.7.0_sr2.0-0.5.1

- SUSE Linux Enterprise Server 11 SP2 (i586):

java-1_7_0-ibm-alsa-1.7.0_sr2.0-0.5.1

- SUSE Linux Enterprise Java 11 SP2 (i586 ppc64 s390x x86_64):

java-1_7_0-ibm-1.7.0_sr2.0-0.5.1
java-1_7_0-ibm-devel-1.7.0_sr2.0-0.5.1
java-1_7_0-ibm-jdbc-1.7.0_sr2.0-0.5.1

- SUSE Linux Enterprise Java 11 SP2 (i586 x86_64):

java-1_7_0-ibm-alsa-1.7.0_sr2.0-0.5.1
java-1_7_0-ibm-plugin-1.7.0_sr2.0-0.5.1


References:

http://support.novell.com/security/cve/CVE-2012-0547.html
http://support.novell.com/security/cve/CVE-2012-0551.html
http://support.novell.com/security/cve/CVE-2012-1682.html
http://support.novell.com/security/cve/CVE-2012-1713.html
http://support.novell.com/security/cve/CVE-2012-1716.html
http://support.novell.com/security/cve/CVE-2012-1717.html
http://support.novell.com/security/cve/CVE-2012-1718.html
http://support.novell.com/security/cve/CVE-2012-1719.html
http://support.novell.com/security/cve/CVE-2012-1721.html
http://support.novell.com/security/cve/CVE-2012-1722.html
http://support.novell.com/security/cve/CVE-2012-1725.html
http://support.novell.com/security/cve/CVE-2012-1726.html
http://support.novell.com/security/cve/CVE-2012-3136.html
http://support.novell.com/security/cve/CVE-2012-4681.html
https://bugzilla.novell.com/780897

http://download.novell.com/patch/finder/?keywords=aedfce1f6badae90c6426f24723192e1

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages