Mailinglist Archive: opensuse-security-announce (37 mails)

< Previous Next >
[security-announce] SUSE-SU-2012:1222-1: important: Security update for ghostscript
SUSE Security Update: Security update for ghostscript
______________________________________________________________________________

Announcement ID: SUSE-SU-2012:1222-1
Rating: important
References: #779700
Cross-References: CVE-2012-4405
Affected Products:
SUSE Linux Enterprise Software Development Kit 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 10 SP4
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Desktop 10 SP4
SLE SDK 10 SP4
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:


This update fixes an array index error leading to a
heap-based buffer overflow in ghostscript-library.
CVE-2012-4405 has been assigned to this issue.

Security Issue reference:

* CVE-2012-4405
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-4405
>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11 SP2:

zypper in -t patch sdksp2-ghostscript-devel-6813

- SUSE Linux Enterprise Server 11 SP2 for VMware:

zypper in -t patch slessp2-ghostscript-devel-6813

- SUSE Linux Enterprise Server 11 SP2:

zypper in -t patch slessp2-ghostscript-devel-6813

- SUSE Linux Enterprise Desktop 11 SP2:

zypper in -t patch sledsp2-ghostscript-devel-6813

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11 SP2 (i586 ia64 ppc64
s390x x86_64):

ghostscript-devel-8.62-32.34.1
ghostscript-ijs-devel-8.62-32.34.1
libgimpprint-devel-4.2.7-32.34.1

- SUSE Linux Enterprise Server 11 SP2 for VMware (i586 x86_64):

ghostscript-fonts-other-8.62-32.34.1
ghostscript-fonts-rus-8.62-32.34.1
ghostscript-fonts-std-8.62-32.34.1
ghostscript-library-8.62-32.34.1
ghostscript-omni-8.62-32.34.1
ghostscript-x11-8.62-32.34.1
libgimpprint-4.2.7-32.34.1

- SUSE Linux Enterprise Server 11 SP2 (i586 ia64 ppc64 s390x x86_64):

ghostscript-fonts-other-8.62-32.34.1
ghostscript-fonts-rus-8.62-32.34.1
ghostscript-fonts-std-8.62-32.34.1
ghostscript-library-8.62-32.34.1
ghostscript-omni-8.62-32.34.1
ghostscript-x11-8.62-32.34.1
libgimpprint-4.2.7-32.34.1

- SUSE Linux Enterprise Server 10 SP4 (i586 ia64 ppc s390x x86_64):

ghostscript-fonts-other-8.15.4-16.28.1
ghostscript-fonts-rus-8.15.4-16.28.1
ghostscript-fonts-std-8.15.4-16.28.1
ghostscript-library-8.15.4-16.28.1
ghostscript-omni-8.15.4-16.28.1
ghostscript-x11-8.15.4-16.28.1
libgimpprint-4.2.7-62.28.1
libgimpprint-devel-4.2.7-62.28.1

- SUSE Linux Enterprise Desktop 11 SP2 (i586 x86_64):

ghostscript-fonts-other-8.62-32.34.1
ghostscript-fonts-rus-8.62-32.34.1
ghostscript-fonts-std-8.62-32.34.1
ghostscript-library-8.62-32.34.1
ghostscript-omni-8.62-32.34.1
ghostscript-x11-8.62-32.34.1
libgimpprint-4.2.7-32.34.1

- SUSE Linux Enterprise Desktop 10 SP4 (i586 x86_64):

ghostscript-fonts-other-8.15.4-16.28.1
ghostscript-fonts-std-8.15.4-16.28.1
ghostscript-library-8.15.4-16.28.1
ghostscript-x11-8.15.4-16.28.1
libgimpprint-4.2.7-62.28.1

- SLE SDK 10 SP4 (i586 ia64 ppc s390x x86_64):

ghostscript-fonts-rus-8.15.4-16.28.1
ghostscript-omni-8.15.4-16.28.1
libgimpprint-devel-4.2.7-62.28.1


References:

http://support.novell.com/security/cve/CVE-2012-4405.html
https://bugzilla.novell.com/779700

http://download.novell.com/patch/finder/?keywords=16655a319f6c06a08b5e85f00894fcfd

http://download.novell.com/patch/finder/?keywords=1dee9fbca1f306bbda3c4a660608088a

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages