Mailinglist Archive: opensuse-security-announce (37 mails)

< Previous Next >
[security-announce] SUSE-SU-2012:1177-1: important: Security update for IBM Java
SUSE Security Update: Security update for IBM Java
______________________________________________________________________________

Announcement ID: SUSE-SU-2012:1177-1
Rating: important
References: #666744 #778629
Cross-References: CVE-2012-1713 CVE-2012-1717 CVE-2012-1718
CVE-2012-1719
Affected Products:
SUSE Linux Enterprise Software Development Kit 11 SP2
SUSE Linux Enterprise Server 11 SP2 for VMware
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 10 SP4
SUSE Linux Enterprise Java 11 SP2
SUSE Linux Enterprise Java 10 SP4
______________________________________________________________________________

An update that fixes four vulnerabilities is now available.

Description:


IBM Java 1.4.2 was updated to SR13 FP13 fixing bugs and
security issues.

http://www.ibm.com/developerworks/java/jdk/alerts/
<http://www.ibm.com/developerworks/java/jdk/alerts/>

Also the following bug has been fixed:

* fix bnc#666744: mark all configuration files as
%config(noreplace)

Security Issue references:

* CVE-2012-1717
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1717
>
* CVE-2012-1713
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1713
>
* CVE-2012-1719
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1719
>
* CVE-2012-1718
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1718
>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11 SP2:

zypper in -t patch sdksp2-java-1_4_2-ibm-6791

- SUSE Linux Enterprise Server 11 SP2 for VMware:

zypper in -t patch slessp2-java-1_4_2-ibm-6791

- SUSE Linux Enterprise Server 11 SP2:

zypper in -t patch slessp2-java-1_4_2-ibm-6791

- SUSE Linux Enterprise Java 11 SP2:

zypper in -t patch slejsp2-java-1_4_2-ibm-6791

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11 SP2 (i586 ia64 ppc64
s390x x86_64):

java-1_4_2-ibm-devel-1.4.2_sr13.13-0.2.1

- SUSE Linux Enterprise Software Development Kit 11 SP2 (i586 x86_64):

java-1_4_2-ibm-1.4.2_sr13.13-0.2.1

- SUSE Linux Enterprise Server 11 SP2 for VMware (i586 x86_64):

java-1_4_2-ibm-1.4.2_sr13.13-0.2.1

- SUSE Linux Enterprise Server 11 SP2 for VMware (i586):

java-1_4_2-ibm-jdbc-1.4.2_sr13.13-0.2.1
java-1_4_2-ibm-plugin-1.4.2_sr13.13-0.2.1

- SUSE Linux Enterprise Server 11 SP2 (i586 ia64 ppc64 s390x x86_64):

java-1_4_2-ibm-1.4.2_sr13.13-0.2.1

- SUSE Linux Enterprise Server 11 SP2 (i586):

java-1_4_2-ibm-jdbc-1.4.2_sr13.13-0.2.1
java-1_4_2-ibm-plugin-1.4.2_sr13.13-0.2.1

- SUSE Linux Enterprise Server 10 SP4 (i586 ia64 ppc s390x x86_64):

java-1_4_2-ibm-1.4.2_sr13.13-0.5.1
java-1_4_2-ibm-devel-1.4.2_sr13.13-0.5.1

- SUSE Linux Enterprise Server 10 SP4 (i586 ppc):

java-1_4_2-ibm-jdbc-1.4.2_sr13.13-0.5.1

- SUSE Linux Enterprise Server 10 SP4 (i586):

java-1_4_2-ibm-plugin-1.4.2_sr13.13-0.5.1

- SUSE Linux Enterprise Java 11 SP2 (i586 ppc64 s390x x86_64):

java-1_4_2-ibm-1.4.2_sr13.13-0.2.1

- SUSE Linux Enterprise Java 11 SP2 (i586):

java-1_4_2-ibm-jdbc-1.4.2_sr13.13-0.2.1
java-1_4_2-ibm-plugin-1.4.2_sr13.13-0.2.1

- SUSE Linux Enterprise Java 10 SP4 (i586 ia64 ppc s390x x86_64):

java-1_4_2-ibm-1.4.2_sr13.13-0.5.1
java-1_4_2-ibm-devel-1.4.2_sr13.13-0.5.1

- SUSE Linux Enterprise Java 10 SP4 (i586 ppc):

java-1_4_2-ibm-jdbc-1.4.2_sr13.13-0.5.1

- SUSE Linux Enterprise Java 10 SP4 (i586):

java-1_4_2-ibm-plugin-1.4.2_sr13.13-0.5.1


References:

http://support.novell.com/security/cve/CVE-2012-1713.html
http://support.novell.com/security/cve/CVE-2012-1717.html
http://support.novell.com/security/cve/CVE-2012-1718.html
http://support.novell.com/security/cve/CVE-2012-1719.html
https://bugzilla.novell.com/666744
https://bugzilla.novell.com/778629

http://download.novell.com/patch/finder/?keywords=1178840a855fef3bb3fdb1b51b3e979e

http://download.novell.com/patch/finder/?keywords=e7a13fdccafdcc81cd4c6d1340a24a02

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages