Mailinglist Archive: opensuse-security-announce (37 mails)

< Previous Next >
[security-announce] SUSE-SU-2012:1148-1: critical: Security update for OpenJDK
SUSE Security Update: Security update for OpenJDK
______________________________________________________________________________

Announcement ID: SUSE-SU-2012:1148-1
Rating: critical
References: #777499
Cross-References: CVE-2012-0547 CVE-2012-1682
Affected Products:
SUSE Linux Enterprise Desktop 11 SP2
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.

Description:


The following security issues have been fixed:

* S7162476, CVE-2012-1682: XMLDecoder security issue
via ClassFinder
* S7163201, CVE-2012-0547: Simplify toolkit internals
references

Security Issue references:

* CVE-2012-1682
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1682
>
* CVE-2012-0547
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-0547
>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Desktop 11 SP2:

zypper in -t patch sledsp2-java-1_6_0-openjdk-6772

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Desktop 11 SP2 (i586 x86_64):

java-1_6_0-openjdk-1.6.0.0_b24.1.11.4-0.3.1
java-1_6_0-openjdk-demo-1.6.0.0_b24.1.11.4-0.3.1
java-1_6_0-openjdk-devel-1.6.0.0_b24.1.11.4-0.3.1


References:

http://support.novell.com/security/cve/CVE-2012-0547.html
http://support.novell.com/security/cve/CVE-2012-1682.html
https://bugzilla.novell.com/777499

http://download.novell.com/patch/finder/?keywords=3a2f76ea954e211ebdec523673a69595

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages