Mailinglist Archive: opensuse-security-announce (29 mails)

< Previous Next >
[security-announce] SUSE-SU-2012:1029-1: important: Security update for gimp
SUSE Security Update: Security update for gimp
______________________________________________________________________________

Announcement ID: SUSE-SU-2012:1029-1
Rating: important
References: #775433
Cross-References: CVE-2012-3403
Affected Products:
SUSE Linux Enterprise Software Development Kit 11 SP2
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Desktop 11 SP1
______________________________________________________________________________

An update that fixes one vulnerability is now available.

Description:


This update of The Gimp fixes a heap overflow that could
have been exploited by attackers to cause a Denial of
Service (application crash) or even to potentially execute
arbitrary code (CVE-2012-3403).

Security Issue reference:

* CVE-2012-3403
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-3403
>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11 SP2:

zypper in -t patch sdksp1-gimp-6683

- SUSE Linux Enterprise Software Development Kit 11 SP1:

zypper in -t patch sdksp1-gimp-6683

- SUSE Linux Enterprise Desktop 11 SP2:

zypper in -t patch sledsp1-gimp-6683

- SUSE Linux Enterprise Desktop 11 SP1:

zypper in -t patch sledsp1-gimp-6683

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11 SP2 (i586 ia64 ppc64
s390x x86_64):

gimp-2.6.2-3.34.37.1
gimp-devel-2.6.2-3.34.37.1
gimp-lang-2.6.2-3.34.37.1
gimp-plugins-python-2.6.2-3.34.37.1

- SUSE Linux Enterprise Software Development Kit 11 SP1 (i586 ia64 ppc64
s390x x86_64):

gimp-2.6.2-3.34.37.1
gimp-devel-2.6.2-3.34.37.1
gimp-lang-2.6.2-3.34.37.1
gimp-plugins-python-2.6.2-3.34.37.1

- SUSE Linux Enterprise Desktop 11 SP2 (i586 x86_64):

gimp-2.6.2-3.34.37.1
gimp-lang-2.6.2-3.34.37.1
gimp-plugins-python-2.6.2-3.34.37.1

- SUSE Linux Enterprise Desktop 11 SP1 (i586 x86_64):

gimp-2.6.2-3.34.37.1
gimp-lang-2.6.2-3.34.37.1
gimp-plugins-python-2.6.2-3.34.37.1


References:

http://support.novell.com/security/cve/CVE-2012-3403.html
https://bugzilla.novell.com/775433

http://download.novell.com/patch/finder/?keywords=ca4c519bd6348192da66901f8d815893

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages