Mailinglist Archive: opensuse-security-announce (29 mails)

< Previous Next >
[security-announce] SUSE-SU-2012:0984-1: important: Security update for MySQL
SUSE Security Update: Security update for MySQL
______________________________________________________________________________

Announcement ID: SUSE-SU-2012:0984-1
Rating: important
References: #765092 #769062
Cross-References: CVE-2012-2122
Affected Products:
SUSE Linux Enterprise Software Development Kit 11 SP2
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Desktop 11 SP1
______________________________________________________________________________

An update that solves one vulnerability and has one errata
is now available. It includes one version update.

Description:


MySQL has been upgraded to version 5.0.96 to fix several
vulnerabilities.

Security Issue reference:

* CVE-2012-2122
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-2122
>
* CVE-2012-0075
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-0075
>
* CVE-2012-0114
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-0114
>
* CVE-2012-0490
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-0490
>
* CVE-2012-0484
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-0484
>
* CVE-2012-0102
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-0102
>
* CVE-2012-0101
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-0101
>
* CVE-2012-0087
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-0087
>
* CVE-2009-5026
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2009-5026
>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11 SP2:

zypper in -t patch sdksp1-libmysqlclient-devel-6613

- SUSE Linux Enterprise Software Development Kit 11 SP1:

zypper in -t patch sdksp1-libmysqlclient-devel-6613

- SUSE Linux Enterprise Server 11 SP2:

zypper in -t patch slessp1-libmysqlclient-devel-6613

- SUSE Linux Enterprise Server 11 SP1 for VMware:

zypper in -t patch slessp1-libmysqlclient-devel-6613

- SUSE Linux Enterprise Server 11 SP1:

zypper in -t patch slessp1-libmysqlclient-devel-6613

- SUSE Linux Enterprise Desktop 11 SP2:

zypper in -t patch sledsp1-libmysqlclient-devel-6613

- SUSE Linux Enterprise Desktop 11 SP1:

zypper in -t patch sledsp1-libmysqlclient-devel-6613

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11 SP2 (i586 ia64 ppc64
s390x x86_64) [New Version: 5.0.96]:

libmysqlclient-devel-5.0.96-0.4.1

- SUSE Linux Enterprise Software Development Kit 11 SP2 (ppc64 s390x x86_64)
[New Version: 5.0.96]:

libmysqlclient_r15-32bit-5.0.96-0.4.1

- SUSE Linux Enterprise Software Development Kit 11 SP2 (ia64) [New Version:
5.0.96]:

libmysqlclient_r15-x86-5.0.96-0.4.1

- SUSE Linux Enterprise Software Development Kit 11 SP1 (i586 ia64 ppc64
s390x x86_64) [New Version: 5.0.96]:

libmysqlclient-devel-5.0.96-0.4.1

- SUSE Linux Enterprise Software Development Kit 11 SP1 (ppc64 s390x x86_64)
[New Version: 5.0.96]:

libmysqlclient_r15-32bit-5.0.96-0.4.1

- SUSE Linux Enterprise Software Development Kit 11 SP1 (ia64) [New Version:
5.0.96]:

libmysqlclient_r15-x86-5.0.96-0.4.1

- SUSE Linux Enterprise Server 11 SP2 (i586 ia64 ppc64 s390x x86_64) [New
Version: 5.0.96]:

libmysqlclient15-5.0.96-0.4.1
libmysqlclient_r15-5.0.96-0.4.1
mysql-5.0.96-0.4.1
mysql-Max-5.0.96-0.4.1
mysql-client-5.0.96-0.4.1
mysql-tools-5.0.96-0.4.1

- SUSE Linux Enterprise Server 11 SP2 (ppc64 s390x x86_64) [New Version:
5.0.96]:

libmysqlclient15-32bit-5.0.96-0.4.1

- SUSE Linux Enterprise Server 11 SP2 (ia64) [New Version: 5.0.96]:

libmysqlclient15-x86-5.0.96-0.4.1

- SUSE Linux Enterprise Server 11 SP1 for VMware (i586 x86_64) [New Version:
5.0.96]:

libmysqlclient15-5.0.96-0.4.1
libmysqlclient_r15-5.0.96-0.4.1
mysql-5.0.96-0.4.1
mysql-Max-5.0.96-0.4.1
mysql-client-5.0.96-0.4.1
mysql-tools-5.0.96-0.4.1

- SUSE Linux Enterprise Server 11 SP1 for VMware (x86_64) [New Version:
5.0.96]:

libmysqlclient15-32bit-5.0.96-0.4.1

- SUSE Linux Enterprise Server 11 SP1 (i586 ia64 ppc64 s390x x86_64) [New
Version: 5.0.96]:

libmysqlclient15-5.0.96-0.4.1
libmysqlclient_r15-5.0.96-0.4.1
mysql-5.0.96-0.4.1
mysql-Max-5.0.96-0.4.1
mysql-client-5.0.96-0.4.1
mysql-tools-5.0.96-0.4.1

- SUSE Linux Enterprise Server 11 SP1 (ppc64 s390x x86_64) [New Version:
5.0.96]:

libmysqlclient15-32bit-5.0.96-0.4.1

- SUSE Linux Enterprise Server 11 SP1 (ia64) [New Version: 5.0.96]:

libmysqlclient15-x86-5.0.96-0.4.1

- SUSE Linux Enterprise Desktop 11 SP2 (i586 x86_64) [New Version: 5.0.96]:

libmysqlclient15-5.0.96-0.4.1
libmysqlclient_r15-5.0.96-0.4.1
mysql-5.0.96-0.4.1
mysql-client-5.0.96-0.4.1

- SUSE Linux Enterprise Desktop 11 SP2 (x86_64) [New Version: 5.0.96]:

libmysqlclient15-32bit-5.0.96-0.4.1
libmysqlclient_r15-32bit-5.0.96-0.4.1

- SUSE Linux Enterprise Desktop 11 SP1 (i586 x86_64) [New Version: 5.0.96]:

libmysqlclient15-5.0.96-0.4.1
libmysqlclient_r15-5.0.96-0.4.1
mysql-5.0.96-0.4.1
mysql-client-5.0.96-0.4.1

- SUSE Linux Enterprise Desktop 11 SP1 (x86_64) [New Version: 5.0.96]:

libmysqlclient15-32bit-5.0.96-0.4.1
libmysqlclient_r15-32bit-5.0.96-0.4.1


References:

http://support.novell.com/security/cve/CVE-2012-2122.html
https://bugzilla.novell.com/765092
https://bugzilla.novell.com/769062

http://download.novell.com/patch/finder/?keywords=35c5a59a35da626d86071585ee93fde8

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages