Mailinglist Archive: opensuse-security-announce (25 mails)

< Previous Next >
[security-announce] SUSE-SU-2012:0575-1: important: Security update for Samba
SUSE Security Update: Security update for Samba
______________________________________________________________________________

Announcement ID: SUSE-SU-2012:0575-1
Rating: important
References: #754443 #757080 #757576
Cross-References: CVE-2012-2111
Affected Products:
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Desktop 11 SP2
SUSE Linux Enterprise Desktop 11 SP1
______________________________________________________________________________

An update that solves one vulnerability and has two fixes
is now available.

Description:


This update of Samba includes the following fixes for two
security issues:

* Ensure that users cannot hand out their own
privileges to everyone, only administrators are allowed to
do that. (CVE-2012-2111
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-2111
> )
* mount.cifs no longer allows unprivileged users to
mount onto dirs that are not accessible to them.
(CVE-2012-1568
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1586
> )

Indications:

Everyone using Samba should update

Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11 SP1:

zypper in -t patch sdksp1-cifs-mount-6210

- SUSE Linux Enterprise Server 11 SP2:

zypper in -t patch slessp1-cifs-mount-6210

- SUSE Linux Enterprise Server 11 SP1 for VMware:

zypper in -t patch slessp1-cifs-mount-6210

- SUSE Linux Enterprise Server 11 SP1:

zypper in -t patch slessp1-cifs-mount-6210

- SUSE Linux Enterprise Desktop 11 SP2:

zypper in -t patch sledsp1-cifs-mount-6210

- SUSE Linux Enterprise Desktop 11 SP1:

zypper in -t patch sledsp1-cifs-mount-6210

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11 SP1 (i586 ia64 ppc64
s390x x86_64):

libnetapi-devel-3.4.3-1.40.3
libnetapi0-3.4.3-1.40.3
libsmbclient-devel-3.4.3-1.40.3
libsmbsharemodes-devel-3.4.3-1.40.3
libsmbsharemodes0-3.4.3-1.40.3
libtalloc-devel-3.4.3-1.40.3
libtdb-devel-3.4.3-1.40.3
libwbclient-devel-3.4.3-1.40.3
samba-devel-3.4.3-1.40.3

- SUSE Linux Enterprise Server 11 SP2 (i586 ia64 ppc64 s390x x86_64):

cifs-mount-3.4.3-1.40.3
libtalloc1-3.4.3-1.40.3

- SUSE Linux Enterprise Server 11 SP2 (ppc64 s390x x86_64):

libtalloc1-32bit-3.4.3-1.40.3

- SUSE Linux Enterprise Server 11 SP2 (ia64):

libtalloc1-x86-3.4.3-1.40.3

- SUSE Linux Enterprise Server 11 SP1 for VMware (i586 x86_64):

cifs-mount-3.4.3-1.40.3
ldapsmb-1.34b-11.28.40.3
libsmbclient0-3.4.3-1.40.3
libtalloc1-3.4.3-1.40.3
libtdb1-3.4.3-1.40.3
libwbclient0-3.4.3-1.40.3
samba-3.4.3-1.40.3
samba-client-3.4.3-1.40.3
samba-krb-printing-3.4.3-1.40.3
samba-winbind-3.4.3-1.40.3

- SUSE Linux Enterprise Server 11 SP1 for VMware (x86_64):

libsmbclient0-32bit-3.4.3-1.40.3
libtalloc1-32bit-3.4.3-1.40.3
libtdb1-32bit-3.4.3-1.40.3
libwbclient0-32bit-3.4.3-1.40.3
samba-32bit-3.4.3-1.40.3
samba-client-32bit-3.4.3-1.40.3
samba-winbind-32bit-3.4.3-1.40.3

- SUSE Linux Enterprise Server 11 SP1 for VMware (noarch):

samba-doc-3.4.3-1.40.3

- SUSE Linux Enterprise Server 11 SP1 (i586 ia64 ppc64 s390x x86_64):

cifs-mount-3.4.3-1.40.3
ldapsmb-1.34b-11.28.40.3
libsmbclient0-3.4.3-1.40.3
libtalloc1-3.4.3-1.40.3
libtdb1-3.4.3-1.40.3
libwbclient0-3.4.3-1.40.3
samba-3.4.3-1.40.3
samba-client-3.4.3-1.40.3
samba-krb-printing-3.4.3-1.40.3
samba-winbind-3.4.3-1.40.3

- SUSE Linux Enterprise Server 11 SP1 (ppc64 s390x x86_64):

libsmbclient0-32bit-3.4.3-1.40.3
libtalloc1-32bit-3.4.3-1.40.3
libtdb1-32bit-3.4.3-1.40.3
libwbclient0-32bit-3.4.3-1.40.3
samba-32bit-3.4.3-1.40.3
samba-client-32bit-3.4.3-1.40.3
samba-winbind-32bit-3.4.3-1.40.3

- SUSE Linux Enterprise Server 11 SP1 (noarch):

samba-doc-3.4.3-1.40.3

- SUSE Linux Enterprise Server 11 SP1 (ia64):

libsmbclient0-x86-3.4.3-1.40.3
libtalloc1-x86-3.4.3-1.40.3
libtdb1-x86-3.4.3-1.40.3
libwbclient0-x86-3.4.3-1.40.3
samba-client-x86-3.4.3-1.40.3
samba-winbind-x86-3.4.3-1.40.3
samba-x86-3.4.3-1.40.3

- SUSE Linux Enterprise Desktop 11 SP2 (i586 x86_64):

cifs-mount-3.4.3-1.40.3
libtalloc1-3.4.3-1.40.3

- SUSE Linux Enterprise Desktop 11 SP2 (x86_64):

libtalloc1-32bit-3.4.3-1.40.3

- SUSE Linux Enterprise Desktop 11 SP1 (i586 x86_64):

cifs-mount-3.4.3-1.40.3
libsmbclient0-3.4.3-1.40.3
libtalloc1-3.4.3-1.40.3
libtdb1-3.4.3-1.40.3
libwbclient0-3.4.3-1.40.3
samba-3.4.3-1.40.3
samba-client-3.4.3-1.40.3
samba-krb-printing-3.4.3-1.40.3
samba-winbind-3.4.3-1.40.3

- SUSE Linux Enterprise Desktop 11 SP1 (x86_64):

libsmbclient0-32bit-3.4.3-1.40.3
libtalloc1-32bit-3.4.3-1.40.3
libtdb1-32bit-3.4.3-1.40.3
libwbclient0-32bit-3.4.3-1.40.3
samba-32bit-3.4.3-1.40.3
samba-client-32bit-3.4.3-1.40.3
samba-winbind-32bit-3.4.3-1.40.3

- SUSE Linux Enterprise Desktop 11 SP1 (noarch):

samba-doc-3.4.3-1.40.3


References:

http://support.novell.com/security/cve/CVE-2012-2111.html
https://bugzilla.novell.com/754443
https://bugzilla.novell.com/757080
https://bugzilla.novell.com/757576

http://download.novell.com/patch/finder/?keywords=e9626ba4d78a73822dfbd0443d19bda0

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
List Navigation
This Thread
  • No further messages