Mailinglist Archive: opensuse-security-announce (19 mails)

< Previous Next >
[security-announce] SUSE-SU-2012:0325-1: important: Security update for puppet
SUSE Security Update: Security update for puppet
______________________________________________________________________________

Announcement ID: SUSE-SU-2012:0325-1
Rating: important
References: #747657
Cross-References: CVE-2012-1053 CVE-2012-1054
Affected Products:
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP1 FOR SP2
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Desktop 11 SP1 FOR SP2
SUSE Linux Enterprise Desktop 11 SP1
______________________________________________________________________________

An update that fixes two vulnerabilities is now available.
It includes one version update.

Description:


This update of puppet fixes two vulnerabilities that could
potentially be exploited by local attackers to escalate
privileges due to improper privilege dropping and file
handling issues (symlink flaws) in puppet (CVE-2012-1053,
CVE-2012-1054).

Security Issue references:

* CVE-2012-1053
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1053
>
* CVE-2012-1054
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-1054
>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Server 11 SP1 for VMware:

zypper in -t patch slessp1-puppet-5876

- SUSE Linux Enterprise Server 11 SP1 FOR SP2:

zypper in -t patch slessp1fsp2-puppet-5876

- SUSE Linux Enterprise Server 11 SP1:

zypper in -t patch slessp1-puppet-5876

- SUSE Linux Enterprise Desktop 11 SP1 FOR SP2:

zypper in -t patch sledsp1fsp2-puppet-5876

- SUSE Linux Enterprise Desktop 11 SP1:

zypper in -t patch sledsp1-puppet-5876

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Server 11 SP1 for VMware (i586 x86_64) [New Version:
2.6.12]:

puppet-2.6.12-0.12.1
puppet-server-2.6.12-0.12.1

- SUSE Linux Enterprise Server 11 SP1 FOR SP2 (i586 ia64 ppc64 s390x x86_64)
[New Version: 2.6.12]:

puppet-2.6.12-0.12.1
puppet-server-2.6.12-0.12.1

- SUSE Linux Enterprise Server 11 SP1 (i586 ia64 ppc64 s390x x86_64) [New
Version: 2.6.12]:

puppet-2.6.12-0.12.1
puppet-server-2.6.12-0.12.1

- SUSE Linux Enterprise Desktop 11 SP1 FOR SP2 (i586 x86_64) [New Version:
2.6.12]:

puppet-2.6.12-0.12.1

- SUSE Linux Enterprise Desktop 11 SP1 (i586 x86_64) [New Version: 2.6.12]:

puppet-2.6.12-0.12.1


References:

http://support.novell.com/security/cve/CVE-2012-1053.html
http://support.novell.com/security/cve/CVE-2012-1054.html
https://bugzilla.novell.com/747657

http://download.novell.com/patch/finder/?keywords=810c76edc7112af5e466c9d5b28e5aa1

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages