Mailinglist Archive: opensuse-security-announce (31 mails)

< Previous Next >
[security-announce] SUSE-SU-2012:0308-1: important: Security update for Java 1.6.0
SUSE Security Update: Security update for Java 1.6.0
______________________________________________________________________________

Announcement ID: SUSE-SU-2012:0308-1
Rating: important
References: #747208
Cross-References: CVE-2011-3563 CVE-2011-3571 CVE-2011-5035
CVE-2012-0497 CVE-2012-0501 CVE-2012-0502
CVE-2012-0503 CVE-2012-0505 CVE-2012-0506

Affected Products:
SUSE Linux Enterprise Desktop 11 SP1 FOR SP2
SUSE Linux Enterprise Desktop 11 SP1
______________________________________________________________________________

An update that fixes 9 vulnerabilities is now available.

Description:


java-1_6_0-openjdk was updated to the IcedTea 1.11.1 b24
release, fixing multiple security issues:

* S7082299, CVE-2011-3571: Fix inAtomicReferenceArray
* S7088367, CVE-2011-3563: Fix issues in java sound
* S7110683, CVE-2012-0502: Issues with some
KeyboardFocusManager method
* S7110687, CVE-2012-0503: Issues with TimeZone class
* S7110700, CVE-2012-0505: Enhance exception throwing
mechanism in ObjectStreamClass
* S7110704, CVE-2012-0506: Issues with some method in
corba
* S7112642, CVE-2012-0497: Incorrect checking for
graphics rendering object
* S7118283, CVE-2012-0501: Better input parameter
checking in zip file processing
* S7126960, CVE-2011-5035: (httpserver) Add property to
limit number of request headers to the HTTP Server

Security Issue references:

* CVE-2011-3571
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-3571
>
* CVE-2011-3563
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-3563
>
* CVE-2012-0502
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-0502
>
* CVE-2012-0503
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-0503
>
* CVE-2012-0505
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-0505
>
* CVE-2012-0506
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-0506
>
* CVE-2012-0497
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-0497
>
* CVE-2012-0501
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2012-0501
>
* CVE-2011-5035
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-5035
>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Desktop 11 SP1 FOR SP2:

zypper in -t patch sledsp1fsp2-java-1_6_0-openjdk-5845

- SUSE Linux Enterprise Desktop 11 SP1:

zypper in -t patch sledsp1-java-1_6_0-openjdk-5845

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Desktop 11 SP1 FOR SP2 (i586 x86_64):

java-1_6_0-openjdk-1.6.0.0_b24.1.11.1-0.3.1
java-1_6_0-openjdk-demo-1.6.0.0_b24.1.11.1-0.3.1
java-1_6_0-openjdk-devel-1.6.0.0_b24.1.11.1-0.3.1

- SUSE Linux Enterprise Desktop 11 SP1 (i586 x86_64):

java-1_6_0-openjdk-1.6.0.0_b24.1.11.1-0.3.1
java-1_6_0-openjdk-demo-1.6.0.0_b24.1.11.1-0.3.1
java-1_6_0-openjdk-devel-1.6.0.0_b24.1.11.1-0.3.1


References:

http://support.novell.com/security/cve/CVE-2011-3563.html
http://support.novell.com/security/cve/CVE-2011-3571.html
http://support.novell.com/security/cve/CVE-2011-5035.html
http://support.novell.com/security/cve/CVE-2012-0497.html
http://support.novell.com/security/cve/CVE-2012-0501.html
http://support.novell.com/security/cve/CVE-2012-0502.html
http://support.novell.com/security/cve/CVE-2012-0503.html
http://support.novell.com/security/cve/CVE-2012-0505.html
http://support.novell.com/security/cve/CVE-2012-0506.html
https://bugzilla.novell.com/747208

http://download.novell.com/patch/finder/?keywords=99d51f474667bf40a87309fbd3de5bbd

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages