Mailinglist Archive: opensuse-security-announce (24 mails)

< Previous Next >
[security-announce] SUSE-SU-2012:0084-1: important: Security update for OpenSSL
SUSE Security Update: Security update for OpenSSL
______________________________________________________________________________

Announcement ID: SUSE-SU-2012:0084-1
Rating: important
References: #739719
Cross-References: CVE-2011-4108 CVE-2011-4109 CVE-2011-4576
CVE-2011-4577 CVE-2011-4619
Affected Products:
SUSE Linux Enterprise Software Development Kit 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 10 SP4
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Desktop 10 SP4
SLE SDK 10 SP4
______________________________________________________________________________

An update that fixes 5 vulnerabilities is now available. It
includes one version update.

Description:


Various security vulnerabilities have been fixed in OpenSSL:

* DTLS plaintext recovery attack (CVE-2011-4108)
* double-free in Policy Checks (CVE-2011-4109)
* uninitialized SSL 3.0 padding (CVE-2011-4576)
* malformed RFC 3779 data can cause assertion failures
(CVE-2011-4577)
* SGC restart DoS attack (CVE-2011-4619)

Security Issue references:

* CVE-2011-4108
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-4108
>
* CVE-2011-4109
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-4109
>
* CVE-2011-4576
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-4576
>
* CVE-2011-4577
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-4577
>
* CVE-2011-4619
<http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2011-4619
>


Patch Instructions:

To install this SUSE Security Update use YaST online_update.
Alternatively you can run the command listed for your product:

- SUSE Linux Enterprise Software Development Kit 11 SP1:

zypper in -t patch sdksp1-libopenssl-devel-5635

- SUSE Linux Enterprise Server 11 SP1 for VMware:

zypper in -t patch slessp1-libopenssl-devel-5635

- SUSE Linux Enterprise Server 11 SP1:

zypper in -t patch slessp1-libopenssl-devel-5635

- SUSE Linux Enterprise Desktop 11 SP1:

zypper in -t patch sledsp1-libopenssl-devel-5635

To bring your system up-to-date, use "zypper patch".


Package List:

- SUSE Linux Enterprise Software Development Kit 11 SP1 (i586 ia64 ppc64
s390x x86_64) [New Version: 0.9.8j]:

libopenssl-devel-0.9.8j-0.26.1

- SUSE Linux Enterprise Server 11 SP1 for VMware (i586 x86_64) [New Version:
0.9.8j]:

libopenssl0_9_8-0.9.8j-0.26.1
openssl-0.9.8j-0.26.1
openssl-doc-0.9.8j-0.26.1

- SUSE Linux Enterprise Server 11 SP1 for VMware (x86_64) [New Version:
0.9.8j]:

libopenssl0_9_8-32bit-0.9.8j-0.26.1

- SUSE Linux Enterprise Server 11 SP1 (i586 ia64 ppc64 s390x x86_64) [New
Version: 0.9.8j]:

libopenssl0_9_8-0.9.8j-0.26.1
openssl-0.9.8j-0.26.1
openssl-doc-0.9.8j-0.26.1

- SUSE Linux Enterprise Server 11 SP1 (ppc64 s390x x86_64) [New Version:
0.9.8j]:

libopenssl0_9_8-32bit-0.9.8j-0.26.1

- SUSE Linux Enterprise Server 11 SP1 (ia64) [New Version: 0.9.8j]:

libopenssl0_9_8-x86-0.9.8j-0.26.1

- SUSE Linux Enterprise Server 10 SP4 (i586 ia64 ppc s390x x86_64):

openssl-0.9.8a-18.56.3
openssl-devel-0.9.8a-18.56.3
openssl-doc-0.9.8a-18.56.3

- SUSE Linux Enterprise Server 10 SP4 (s390x x86_64):

openssl-32bit-0.9.8a-18.56.3
openssl-devel-32bit-0.9.8a-18.56.3

- SUSE Linux Enterprise Server 10 SP4 (ia64):

openssl-x86-0.9.8a-18.56.3

- SUSE Linux Enterprise Server 10 SP4 (ppc):

openssl-64bit-0.9.8a-18.56.3
openssl-devel-64bit-0.9.8a-18.56.3

- SUSE Linux Enterprise Desktop 11 SP1 (i586 x86_64) [New Version: 0.9.8j]:

libopenssl0_9_8-0.9.8j-0.26.1
openssl-0.9.8j-0.26.1

- SUSE Linux Enterprise Desktop 11 SP1 (x86_64) [New Version: 0.9.8j]:

libopenssl0_9_8-32bit-0.9.8j-0.26.1

- SUSE Linux Enterprise Desktop 10 SP4 (i586 x86_64):

openssl-0.9.8a-18.56.3
openssl-devel-0.9.8a-18.56.3

- SUSE Linux Enterprise Desktop 10 SP4 (x86_64):

openssl-32bit-0.9.8a-18.56.3
openssl-devel-32bit-0.9.8a-18.56.3

- SLE SDK 10 SP4 (i586 ia64 ppc s390x x86_64):

openssl-doc-0.9.8a-18.56.3


References:

http://support.novell.com/security/cve/CVE-2011-4108.html
http://support.novell.com/security/cve/CVE-2011-4109.html
http://support.novell.com/security/cve/CVE-2011-4576.html
http://support.novell.com/security/cve/CVE-2011-4577.html
http://support.novell.com/security/cve/CVE-2011-4619.html
https://bugzilla.novell.com/739719

http://download.novell.com/patch/finder/?keywords=00effca53ebc7841a642ba4e7eeaa0b9

http://download.novell.com/patch/finder/?keywords=16f27ddd5506ebb38dc0015501b071d9

--
To unsubscribe, e-mail: opensuse-security-announce+unsubscribe@xxxxxxxxxxxx
For additional commands, e-mail: opensuse-security-announce+help@xxxxxxxxxxxx

< Previous Next >
This Thread
  • No further messages